Crash on startup - unexpected keyword argument 'transactional'

Bug #672454 reported by Abel Tamayo on 2010-11-08
102
This bug affects 21 people
Affects Status Importance Assigned to Milestone
wiithon
Undecided
Carlo Mandelli

Bug Description

Usando la última version disponible y recién descargada de Launchpad (1.16) me da el siguiente error en terminal:

Traceback (most recent call last):
  File "/usr/games/wiithon", line 15, in <module>
    from cli import WiithonCLI
  File "/usr/share/wiithon/cli.py", line 11, in <module>
    from wiitdb_schema import Particion
  File "/usr/share/wiithon/wiitdb_schema.py", line 32, in <module>
    session = util.getSesionBDD(db)
  File "/usr/share/wiithon/util.py", line 377, in getSesionBDD
    session = Session()
  File "/usr/lib/python2.6/dist-packages/sqlalchemy/orm/scoping.py", line 52, in __call__
    return self.registry()
  File "/usr/lib/python2.6/dist-packages/sqlalchemy/util.py", line 1266, in __call__
    val = self.registry.value = self.createfunc()
  File "/usr/lib/python2.6/dist-packages/sqlalchemy/orm/session.py", line 176, in __init__
    super(Sess, self).__init__(**local_kwargs)
TypeError: __init__() got an unexpected keyword argument 'transactional'

He probado borrando bases de datos y archivos antiguos para obligarle a crear nuevos pero no he conseguido nada :(

Revision history for this message
Gonzalo Cao (gonzalo-cao) wrote :

Mismo error, usando ubuntu 10.10. En ubuntu 10.04 funciona correctamente. Debe ser algo relacionado con la versión de python o sus librerías

Tom Ellis (tellis) on 2010-11-08
Changed in wiithon:
status: New → Confirmed
Revision history for this message
Pablo Catalina (xkill) wrote :

Same with Ubuntu 10.10.

Revision history for this message
Mike23 (m-caresana) wrote :

i'm affect too. any idea??

Revision history for this message
Pablo Catalina (xkill) wrote :

I tried the svn trunk release, and it works.
But the Ubuntu package at 10.10 doesn't work.

Revision history for this message
Christoph Shipley (champro) wrote :

I've combined the tickets I believed were duplicates to this one (since it's the oldest). The bug happens in build 493 from the development version of Wiithon, when installed on Maverick.

summary: - Error on start up
+ Crash on startup - unexpected keyword argument 'transactional'
Revision history for this message
Carlo Mandelli (camandel) wrote :

What version of python-sqlalchemy are you using?

Revision history for this message
sk (sk-valshk) wrote :

python-sqlalchemy 0.6.3-2 in Linuxmint 10 (Ubuntu10.10).

Revision history for this message
Carlo Mandelli (camandel) wrote :

This bug should have been fixed in development version from r489.
Please, could you confirm that this error happens only on stable version (1.16)?

Revision history for this message
Carlo Mandelli (camandel) wrote :

Fix committed in r405.
Pleae test it with sqlalchemy >= 0.6.x

Changed in wiithon:
status: Confirmed → Fix Committed
assignee: nobody → Carlo Mandelli (camandel)
Revision history for this message
Extasy (henrik-nyberg) wrote :

When opening a wbfs disk I get information from wiithon informing me that cover art is missing and get a choice to download it. When choosing to download the missing cover arts it fails with a blank screen informing me it failed, the whole application freezes.

I'm on ubuntu 10.10 with the newest development version for Kermic. I have no other problem running the application! I'm happy to see you again Carlo! You have done an excellent work with this application!

Revision history for this message
Asterix1423 (2cops) wrote :

Hello,

I did a reinstall of Linux Mint 10 (Ubuntu10.10 devirate) and have the same problem as listed in the first posting. I understand that there is no fix yet?

Revision history for this message
Asterix1423 (2cops) wrote :

Ok

I finally succeeded to locate, find and download the latest build, r489. I installed it and the problem seems to be solved. The program did start up.

Revision history for this message
PabloRQ (pablo-romeroquinteros) wrote :

Same bug on Ubuntu 10.10 installed from stable version with this command:
$ grep "deb http://ppa.launchpad.net/wii.sceners.linux/wiithon-1.1/ubuntu karmic main" /etc/apt/sources.list || echo deb http://ppa.launchpad.net/wii.sceners.linux/wiithon-1.1/ubuntu karmic main | sudo tee -a /etc/apt/sources.list && sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 1F882273

Then installed wiithon from synaptic.

When runned from menu, nothing happens.

when runned from terminal, you can see the 'TypeError: __init__() got an unexpected keyword argument 'transactional'' error.

Revision history for this message
PabloRQ (pablo-romeroquinteros) wrote :

Tested development version and works!

Added the development repository:
$ grep "deb http://ppa.launchpad.net/wii.sceners.linux/wiithon/ubuntu karmic main" /etc/apt/sources.list || echo deb http://ppa.launchpad.net/wii.sceners.linux/wiithon/ubuntu karmic main | sudo tee -a /etc/apt/sources.list && sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 1F882273

In synaptic:
- Disable the old (stable) repository (.../wii.sceners.linux/wiithon-1.1/...)
- Reload repositories
- Update wiithon

Launched from menu - works!

Changed in wiithon:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions