Error dicovering wiimote - Error decubriendo Wiimote

Reported by Eduardo Martínez on 2010-08-21
This bug report is a duplicate of:  Bug #501435: Error discovering Wiimote. Edit Remove
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
WiiCan
Undecided
Unassigned

Bug Description

Hi, im spanish, the deplovement team are spanish, and my english its so bad, so for that i want to express in spanish, sorry to english speakers.

-- Translated into english by J. Félix Ontañón

Hi, i don't know exactly how the bug reporting works, first of all thanks for doing this, if you don't move i don't have an ideal Fceux HID and it seems you're the one with GUI.

In the begining the app worked rather well, so i decided to do my own script and then it didn't connect anymore and tell me my script contains syntax errors. I revised the script and found nothing. I tried to copy your provided mouse script on mine and it continued with errors: "Error discovering wiimote, review the mapping syntax". I got exhausted: it only worked with the two provided mappings, so i modified one of the official and it worked! .. till two restarts.

So the app doesn't work, it's unstable after the third restart, more or less, it gets blocked, doesn't respond, and don't connect with any script. I tried to put the original mapping, "mouse", it didn't worked.

I feel strange at the begining it worked not now. I don't mind it's perms issues, i suppose it never get worked. Looking a similar conecction bug didn't solve nothing. Reinstall it's my last try. Anyway, it worked at the begining, so i suppose it's a way to solve it with no need to reinstall.

Thanks for your work and if you know how to solve just tell me. Maybe in next versions. Thanks!

-- Original text

Hola, no se muy bien como rula esto de los reportes de error, lo primero gracias por hacer esto, si no movéis el culo me quedo sin un HID ideal para el Fceux, y al parecer sois los únicos con una GUI.

Resulta que el programa al principio funcionaba de puta madre, hasta que decidí hacer mi propio script, entonces me dejo de conectar y me decía que mi script tenia un error de sintaxis, revise y revise el script y nada, ademas que mas simple no podía ser. Así que probé copiando un script echo por vosotros (mouse) en mi script, y curiosamente me seguía diciendo que tenia un error de sintaxis "Error descubriendo wiimote, revisa la sintaxis de tu mapeo". Ya me desespere y resulta que solo emparejaba con el wiimote cuando seleccionaba uno de los 2 scripts que venían de serie; así que se me ocurrió la triquiñuela, modificar el script "mouse" a mi gusto, y funciono... durante 2 reinicios.

Ahora el programa esta totalmente inservible, de entrada es inestable a partir del tercer intento de conexión o así, se bloquea y no responde, y no me conecta con ningún script, he intentado volver a dejar como estaba el script "mouse" y nada.

Me parece un poco raro que al principio funcione y luego ya no, no creo que sea nada de concesión de permisos o faltas de dependencias, porque de ser así supongo que nunca hubiera funcionando. He mirado un bug conocido de conexión pero no me soluciona nada, solo me queda probar a reinstalar. No obstante, como me llego a funcionar, supongo que habrá alguna solución sin necesidad de reinstalar.

Bueno, gracias por vuestra labor, si sabéis como puedo solucionarlo avisad, si no espero podáis solventar esto en versiones futuras, muchas gracias.

description: updated
J. Félix Ontañón (fontanon) wrote :

Hi Eduardo,

As you can see i've translated your bug report into english for the wiican community. I encourage you to use english so the world could help you, not only the spanish wiican users. About how to report bugs maybe this could help you[1]. It's a good spanish article about bug reporting. Please, don't use any rude words.

I suppose you're running wiican 0.2.x series, isn't? I'm sure you're suffering lp:501435 bug and i'll mark this bug as duplicated.

About your wiican scripts and syntax errors, i'm about to launch wiican 0.3 and a lot of bugs will be closed and with the new import/export mapping features i'm sure you'll get fceux working very well. If you know how to get the wiican 0.3 branch maybe you could try it now.

[1] http://www.chiark.greenend.org.uk/~sgtatham/bugs-es.html

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers