Checkboxes should react when hovered by the mouse cursor

Bug #990623 reported by Hans Joachim Desserud on 2012-04-28
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
widelands
Wishlist
Unassigned

Bug Description

Currently if you hover the cursor over any of the buttons, they change to a lighter color to indicate they are clickable (/manipulatable). This is common behaviour for all part of the interface a user can interact with.

Checkboxes currently does not react when the cursor hover above them, so this functionality needs to be added. The checkboxes' graphics were recently upgraded, including graphics to indicate similar behaviour so everything is in place, only the code needs to be added.

(See also bug 986534, especially comment #11)

Tags: ui Edit Tag help
Chuck Wilder (chuckw20) wrote :

Actually the mouse-over graphics for the checkboxes have not yet been added, but they can easily be made available.

Hans Joachim Desserud (hjd) wrote :

Hm, seems like the checkboxes have an extremely limited hover effect already (though this might be a bug).
1. Move the cursor over a checkbox.
2. Click on it to toggle the status.
3. Keep an eye on the checkbox border.
4. Move the cursor and observe the checkbox border.

Just after it has been clicked and before the cursor is moved there is a noticable difference in the border, though I am not sure where this comes from.

Chuck Wilder (chuckw20) wrote :

I have witnessed what you describe, hjd. IMHO, it is not a true hover feature but the result of some transparency in the borders. The new image temporarily overlays the original image until the mouse pointer is moved. By moved, I mean any movement of even just a pixel from its position when the click was performed results in the erasure of the underlying (original) graphic. So, I attribute this anomaly to transparency in the borders that reveals the mechanics of the image change.

Nasenbaer (nasenbaer) on 2012-05-02
Changed in widelands:
status: New → Confirmed
Gabriel Margiani (gamag) wrote :

Looking at the code, I found that this border change is, or better should be a hover effect. The Problem was that the statebox class needed to handle mousemove to use the handle_mousein method.
I fixed this in rev 6378.
The hover rectangle should be outside of the checkbox border on all sides, but in the right, it lays on top of it and I couldn't make it more width. (say: the hover highlight can't be a square bigger than the checkbox and is a rectangle instead.) I don't know why.
So look at it and decide if this bug is fixed or the mouse-over pics should be implemented...

Nasenbaer (nasenbaer) wrote :

No answers for months and I am pretty sure that the new and current behaviour looks good, so I set this to fix committed.
Thanks gamag :)

Changed in widelands:
status: Confirmed → Fix Committed
Hans Joachim Desserud (hjd) wrote :

Wow. I must have completely forgotten about this one. And yes, I'm happy with the current checkboxes. :)

SirVer (sirver) wrote :

Released in build-18 rc1.

Changed in widelands:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers