Decreasing vision for node that is not seen

Bug #985109 reported by Angelo Locritani on 2012-04-18
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
widelands
Low
Unassigned

Bug Description

when loading the attached savegame, saved with build17rc2, the following messages appear on console.

Decreasing vision for node that is not seen. Report bug!

So I'm reporting :)

The game loads normally.

Angelo Locritani (alocritani) wrote :

I am not sure where this comes from.
It can happen when a node is hidden via lua scripting - which makes
sense. But when no scripting is involved, this should not show up (in my
understanding anyways)

Angelo Locritani (alocritani) wrote :

Not sure if this can help, but can it be related to using scout?
I've never seen this errors on savegames without scouts, but it can be a
chance...

Il giorno 18 aprile 2012 22:38, SirVer <email address hidden> ha
scritto:

> I am not sure where this comes from.
> It can happen when a node is hidden via lua scripting - which makes
> sense. But when no scripting is involved, this should not show up (in my
> understanding anyways)
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/985109
>
> Title:
> Decreasing vision for node that is not seen
>
> Status in Widelands:
> New
>
> Bug description:
> when loading the attached savegame, saved with build17rc2, the
> following messages appear on console.
>
> Decreasing vision for node that is not seen. Report bug!
>
> So I'm reporting :)
>
> The game loads normally.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/widelands/+bug/985109/+subscriptions
>

Hans Joachim Desserud (hjd) wrote :

Fwiw, I've seen this message when loading save games as well.

Changed in widelands:
importance: Undecided → Low
status: New → Confirmed
tags: added: savegame

I have disabled this now in the scenarios branch by removing the
warning - also comments in the code. The original comment was based on
the assumption that only military buildings increase or decrease vision
for nodes - but this is no longer the case.

  status inprogress
  milestone build18-rc1

Changed in widelands:
milestone: none → build18-rc1
status: Confirmed → In Progress
Nasenbaer (nasenbaer) wrote :

As I am pretty sure, that we won't merge the scenario branch prior to build18, I just applied the diff from mentioned revision and committed in to trunk in bzr revision 6709 -> Fix committed

Changed in widelands:
status: In Progress → Fix Committed
SirVer (sirver) wrote :

Released in build-18 rc1.

Changed in widelands:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments