increase and decrese resource tool has methods with multiple consecutive returns

Bug #975847 reported by Hans Joachim Desserud on 2012-04-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
widelands
Low
Unassigned

Bug Description

(Found by utils/create_cppcheck_report)

src/editor/tools/editor_decrease_resources_tool.cc:95 and src/editor/tools/editor_increase_resources_tool.cc:138 both have two consecutive return statements. The easiest fix would be to remove the second one "return 0;", but as I don't know the code, I am not sure what the intended behaviour is here.

Gabriel Margiani (gamag) wrote :

fixed in rev6374.

Changed in widelands:
status: Triaged → Fix Committed
SirVer (sirver) wrote :

Released in build-18 rc1.

Changed in widelands:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers