Cannot see which map I am currently playing

Bug #965052 reported by Astuur on 2012-03-26
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
widelands
Wishlist
Unassigned

Bug Description

I would like to see which map I am on from _inside_ the game.
A good place to display this might be the headline of the
minimap view, but other place can certainly be found.

Sounds a bit silly, I know.
But when you run different games on different machines in you LAN
you may well forget it.
Hope it's an easy one.

Tags: ui Edit Tag help
Hans Joachim Desserud (hjd) wrote :

>But when you run different games on different machines in you LAN
you may well forget it.

/me imagines a room filled with computers each running different Widelands games. Sounds awesome.

I am not sure about the map window, since it tends to be quite small on smaller maps. Especially when taking translations into consideration, I think it would be hard to fit the entire title in the map window title.

I had another idea though. At the beginning of each game, you receive message informing you which win condition is set and details for how to win the game. I think it would be fairly easy to alter this to also list the name of the map you are currently playing. This would then be possible to look up later in the inbox/archive in case the player has forgotten map name and/or win conditions.

Changed in widelands:
status: New → Confirmed
importance: Undecided → Wishlist
Astuur (wolfsteinmetz) wrote :

Not in one room, HJD :)
I just want to have this info somewhere to look it up - it doesn't matter much where it is.

cghislai (charlyghislain) wrote :

You can now see it in the save dialog, which should not preselect any other game than the current one with a recent commit.

Changed in widelands:
status: Confirmed → Fix Committed
Changed in widelands:
milestone: none → build18-rc1
SirVer (sirver) wrote :

Released in build-18 rc1.

Changed in widelands:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers