Add option to burn a ship

Bug #963802 reported by Astuur on 2012-03-24
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
widelands
Wishlist
Unassigned

Bug Description

Just like with any building there should be a way to destroy a ship.
It may be wrongly placed, in the way, or no more needed.
Currently there is no way to get rid of a ship AFAIK.

Hans Joachim Desserud (hjd) wrote :

I agree this should be possible. Perhaps even dismantling?

Changed in widelands:
importance: Undecided → Wishlist
status: New → Confirmed
tags: added: seafaring ships
Patrick H. (daggeteo) wrote :

I like the idea of being able to destroy or dismantle the ships.

Nasenbaer (nasenbaer) on 2012-04-11
tags: removed: ships
Frank Pieper (frank-pieper-1) wrote :

I think there should be multiple different Exit-Alternatives from regular Service. Burning is one, Sinking another, running on Ground a third, crushing into Clips the fourth. Player's like alternative Methods to lose their Ships with Load. Dismantling a Ship is reasonable but most suited Facility is a ShipsDock. With a Damage-Model and Aging for Ships that Dock gets rather useful. Dismantling close to the ShipYard could be a Way as well.

SirVer (sirver) wrote :

Burning is enough imho. There should be very little reason to ever do so - only when you failed to stop your shipwright. And then there does not need to be 20 options - just get rid of the ship.

Frank Pieper (frank-pieper-1) wrote :

I did not mean crushing a Ship is a reasonable Alternative if the ShipWright did another Time OverProduktion.

SeeFaring was an Advanture in old Days and is partially still today. Even HollyWood won't let Ships burn due to they run on Ground. If we want to cover most likely Exit-Events for a Ship then we may cover these as well due to they should be rather similar in Code-Structure aside of additional Checks of Terrain if the Ship can crush Clipps there (Clipps?), can run on Ground (! Deep Sea) or sink (! Shallow Water).

SirVer (sirver) wrote :

Adding in random events that destroy your ships outside of campaigns seems like a bad idea to me - in campaigns it could be a challenging and interested thing to do. But random events of this magnitude in general multiplayer makes chance being a big thing and this is not fun for anyone involved.

Also, explaining the impact of age onto a ship is hard to convey in the world of widelands where there is no erosion. So -1 for all ideas voiced so far except for burning ships from my side.

Gabriel Margiani (gamag) wrote :

I agree with #6, except that sinking not burning a ship seems to me the most natural way of getting rid of it.

Nasenbaer (nasenbaer) on 2013-07-31
Changed in widelands:
assignee: nobody → Nasenbaer (nasenbaer)
milestone: none → build18-rc1
Nasenbaer (nasenbaer) wrote :

Fix committed in bzr rev 6707.
The ship is simply removed - no animation is played. Implementation of such an animation should be quite straight forward via m_ship_state. However that would be only a graphic addon, and as sinking a ship works now, I set this bug to fix committed for now.

Changed in widelands:
status: Confirmed → Fix Committed
Hans Joachim Desserud (hjd) wrote :

Please see bug 1209356 regarding the animation.

Nasenbaer (nasenbaer) on 2013-08-08
Changed in widelands:
assignee: Nasenbaer (nasenbaer) → nobody
SirVer (sirver) wrote :

Released in build-18 rc1.

Changed in widelands:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers