Port build help icon shown, though no port can be build

Bug #963697 reported by Astuur on 2012-03-24
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
widelands
Undecided
Unassigned

Bug Description

bzr6334
The blue buildhelp icon for "Port" is shown when the port-plot is close to the border.
In that case you can see that this is a port plot, but you cannot actually build a port there,
because the plot is still "medium" (or even small?) size, and the ports needs a large plot.
This behaviour is different from the rest of the build help and a bit misleading.
With the option of possible additional marine buildings on the shoreline in mind (colonization?)
I'd suggest to create a "blue medium plot with an anchor" (small too?)
and have the buildhelp display these two marine assiciated plots sizes discriminative
just like the normal buildhelp does.

Actually it is correct that the icon is shown imho. Otherwise, you could
acidentally overbuild a harbor space when it is close to your border and
it is not yet displayed as harbor. But of course it is wrong that you
cannot really build a harbor there yet. My suggestion is to relay the
rules for harbor buildings and allow them being placed even if there is
not enough room for big buildings due to the border yet.

I am against medium and small harbor buildings. I do not think we should
overdo it with the different buildings on shores.

Nasenbaer (nasenbaer) wrote :

I agree with #1 - as harbours will be buildable on completely unowned land in future as soon as colonization is implemented.

Chuck Wilder (chuckw20) wrote :

What about incidents where tree growth has rendered the port space unbuildable? Would/should the port space build icon still be displayed?

Astuur (wolfsteinmetz) wrote :

I personally like the idea that a port space should need be "discovered" if it is overgrown
or hidden under rocks.

SirVer (sirver) wrote :

Yet another reason to get rid of this silly feature :P. sorry, couldn't resist. IMHO it is not worth special casing - the map designer can make the area around the port dry to make trees unlikely or give players a hint to look for port places (eg by designing islands)

Astuur (wolfsteinmetz) wrote :

What do you mean by "silly feature"?
The auto-spreading trees?
I deeply disliked them when I first met them in WL
but I just love them now, and would miss them dearly.
But there is nothing wrong with hidden port plots IMO.
You need to clear the space to find big plots, so why not
for finding port spaces?
Fine with me.

>What do you mean by "silly feature"?
>The auto-spreading trees?
Yep. But this feature has been discussed quite in-depth already and I
was overruled by a majority, i.e. I am pretty much alone (with Kristin!)
in hating this feature. I just use every opportunity to bring it up
again to sting a bit - but I do not really want to make it a topic
again. Sorry for derailing this thread slightly. back to topic.

>You need to clear the space to find big plots, so why not
>for finding port spaces?
>Fine with me.
I agree. The only problem is when a player cannot find it and it is a
necessity to advance on the map in the scenario. It is similar to some
maps where you need a big spot to build a castle or you can't advance
and they are easy to be missed or destroyed too.

Nasenbaer (nasenbaer) on 2012-04-11
tags: added: seafaring
Nasenbaer (nasenbaer) on 2013-06-16
Changed in widelands:
milestone: none → build18-rc1
Nasenbaer (nasenbaer) on 2013-06-19
Changed in widelands:
status: New → Confirmed
Nasenbaer (nasenbaer) wrote :

I first of all thought the same as SirVer in #1, however during implementation of the fix for this bug, I worked on too many small special cases and finally cam across the problem, that building a port on the border would mean initial conquering of two more fields to make sure, that the port is standing completely in the land of the player - of course that behaviour would be similar to colonizing an island, but well... to be serious the way to colonize is different to the one to build a port in already occupied land.

To conclude:
Special casing the port buildicon behaviour would brake the game concept at that place and would definitely lead to confusion for players and finally to more bug reports about said behaviour. Therefore I just made the icons be shown as they should be after the normal design.

Concerning the possibility to "overbuild" a port buildspace: of course there is a small chance, that exactly that will happen, if the player sees the space on it's border, but does not yet see the port buildspace icon, however if the border is just one or two linesin front (so the buildspace of the port is not in the area of the player until now), constructing a building on the baseflag of the port buildspace or constructing a building very close to the port buildspace would make it unusable as well, so the special casing would only fix one specific case where a player would face this "i did not even see, that this is a port buildspace" problem.

However this is a personal matter of taste (but as well a point of game design), so if someone disagrees, the discussion is open :)

For now: fix in bzr rev. 6591

Changed in widelands:
status: Confirmed → Fix Committed
assignee: nobody → Nasenbaer (nasenbaer)
SirVer (sirver) wrote :

#3 is a very real concern though - in the over the horizon map threes have overgrown my port space before and I did not find it for a long time.

Nasenbaer (nasenbaer) wrote :

@SirVer (#9):
I know you dislike the automatic tree growing feature ;) ...

Anyway as you wrote in #5 yourself, this is a matter of map design. And the "Over the horizon" map is still WIP - improved terrain placement for port spaces can still be added to the map and by the way: there might be map designers who would like to design dynamic deep mangrove forests who cover port buildspaces. :)

So this would not be a reason for me to change anything.

Nasenbaer (nasenbaer) on 2013-07-31
Changed in widelands:
assignee: Nasenbaer (nasenbaer) → nobody
SirVer (sirver) wrote :

Released in build-18 rc1.

Changed in widelands:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers