Editor crashes when trying drag and drop of tool

Bug #952810 reported by Venatrix on 2012-03-12
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
widelands
Medium
Gabriel Margiani

Bug Description

Reproduce:

1. Open the editor.
2. Open the tool window.
3. Choose any tool and try to drag and drop it onto the map.

The editor will crash with a segmentation fault and no further information.

When you first use a tool without trying to drag it, you can’t trigger the crash anymore.

Venatrix (elisabeth) wrote :

Oh yes, that was r6308 on Lubuntu 11.10

Hans Joachim Desserud (hjd) wrote :

Confirmed. It crashes when dragging something the moment you move the cursor outside the tool window.

Has the editor supported drag and drop in the past, or is this simply the first time anyone has spotted this issue?

Changed in widelands:
importance: Undecided → Medium
status: New → Confirmed
Hans Joachim Desserud (hjd) wrote :

I have attached a backtrace from gdb when the crash occurs.

Gabriel Margiani (gamag) on 2012-03-17
Changed in widelands:
assignee: nobody → Gabriel Margiani (gamag)

Fixed in r6322

 status fixcommited

Changed in widelands:
status: Confirmed → Fix Committed
Shevonar (shevonar) wrote :

Since there is no feature freeze until now and it is in trunk, it will make it in build17

Changed in widelands:
milestone: none → build17-rc1
SirVer (sirver) wrote :

Released in build17-rc1.

Changed in widelands:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments