Maps descriptions not translated even if translations exist

Bug #931902 reported by Angelo Locritani on 2012-02-14
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
widelands
Undecided
Unassigned

Bug Description

For the following maps, translations exist but they are not displayed.

Atoll
Desert Tournament
Elven Forests
Four Castles
Four Mountains
Rendez-Vous
Swamp Monks
Sun of fire

In their "elemental" file all share the same structure of the descr parameter:

descr=_""For hundreds of years this island was kept as sanctuary of the Gods. No human ever ventured to set a foot on it. But now, that a tribe was finally barefaced enough to settle on the coast of that island, a lot others followed afterwards."
" "
_"Start positions are clockwise""

On this map, the description is not translatable at all (missing _ in front of the string):
Together we're strong.wmf

Angelo Locritani (alocritani) wrote :

further details:
it seems that translations for

Atoll
Desert Tournament
Elven Forests
Four Castles
Four Mountains
Rendez-Vous
Swamp Monks
Sun of fire

do exist in .po/.pot files but not in the launchpad translation section (no possibility to translate it at all)

Nasenbaer (nasenbaer) wrote :

this is most likely due to the addition of the second sentence added to the back of the main description ( "Start positions are clockwise" or "Suggested teams...")

Tino (tino79) wrote :

It has been quite some time since the translation catalogs in trunk were updated (i think dec'11).
There are also some strings in the ui which are now translatable (_ in sourcecode), but not available in launchpad.

There was a discussion regarding the correct procedere. For now a simple update of the catalogs render many strings to untranslated, because launchpad does not support fuzzy translations...

The catalogues have been updated now (twice in fact last night :)). The
non support of fuzzy strings is out of our control - we cannot treat
around it and must live with it for the moment. Please all pressure the
launchpad guys to finally get this rolling.

Angelo Locritani (alocritani) wrote :

I've not checked rebuilding translations, but the description of Four Mountains map is still missing from launchpad, while other changes are there. Also, checking changes on maps.pot, no change seem to be focused on descriptions.

Even stranger, translations exists in .po files (at least in it.po - http://bazaar.launchpad.net/~widelands-dev/widelands/trunk/view/head:/po/maps/it.po rows 167) but they are not used in game or shown in launchpad.

I fear that having twice double quotes at the beginning of a translatable string could create problems.

example:
descr=_""For hundreds of years this ...

Nasenbaer (nasenbaer) wrote :

I can confirm. The buildcat.py script obviously does not grap the text for translation.

> Even stranger, translations exists in .po files (at least in it.po -
> http://bazaar.launchpad.net/~widelands-dev/widelands/trunk/view/head:/po/maps/it.po rows 167)
> but they are not used in game or shown in launchpad.

this is not strange :) - this is because the translations existed before. The po files are just outdated, because the have not been merged in last time. Why they are not translated is simply because the strings differ at some places.

Changed in widelands:
status: New → Confirmed
milestone: none → build17-rc1
Nasenbaer (nasenbaer) wrote :

Fix committed in rev. 6223

I remembered, that there was a similiar problem before a long time ago with the campaign texts - and yes it was, as suggested, the "" at the beginning. The new formation fixed it.

Changed in widelands:
status: Confirmed → Fix Committed
SirVer (sirver) wrote :

Released in build17-rc1.

Changed in widelands:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers