island hoping, transfer to 3. island leaves soldiers and military items on 2. island

Bug #905974 reported by Borim on 2011-12-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
widelands
Undecided
Unassigned

Bug Description

hallo,

I played island hoping in a 1 vs 1 match. My opponent jumped to the 3. island before me, and expand quickly to the center and my starting point on the 3. island.
When I jumped to the 3. island, I was in his attack range. Of course I was immeadatly under assult and to my surprise my new Hq was destroyed instantly. None of my soldiers came out to defend my border.

That was weird, as there should be about 20 soldiers in my Hq, and more items to produce newby soldiers. Checking the stored items on my 2. island, all my soldiers and military equipment, was still there. Only the building material was transfered to the 3. island.

I expected that all items and units stored on island 1 and 2 would be transfered to the 3. island.

revision 6153, windows

Borim (borim) wrote :
SirVer (sirver) wrote :

sounds weird - if the build items were transferred, the other items must be as well. This is all handled in the same loop. I will investigate this.

Changed in widelands:
status: New → Incomplete
assignee: nobody → SirVer (sirver)
milestone: none → build17-rc1
Borim (borim) wrote :

This "bug" is one example for: learn reading!
Only the wares and bobs in each hq are transferred to the next isle.

I build a warehouse on the second isle to solve some transportation issues. As my warehouse was closer to the training and production buildings, all my soldiers and military equipment were stored there. In the end my soldiers had a nice break, when I jumped to the 3. isle and wonder why some bright lights are shining at the horizion :-/

So to make it short, this was not a bug. I just expected another behaviour.

In my eyes it does not make much sense to keep the wares in the wareshouses and only move the wares in the hq. There is no reason to threat them in an other way. So I think all stored wares should be transfered to the next isle.

How do you see it?

SirVer (sirver) wrote :

I agree. Should be easy to fix.

Changed in widelands:
status: Incomplete → Confirmed
SirVer (sirver) wrote :

From your original bug report it was not clear to me that all stuff from hqs were transported, you said all build wares only. Your last comment made things clearer to me.

Borim (borim) wrote :

Yeah sorry for the unclear report, I was not sure myself what happen. I have to analyse the save game first and tested my suspicion, today ;)

SirVer (sirver) wrote :

Fixed now. Wares from all warehouses are transfered as well.

Changed in widelands:
status: Confirmed → Fix Committed
assignee: SirVer (sirver) → nobody
SirVer (sirver) wrote :

Released in build17-rc1.

Changed in widelands:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments