Need new icon for port buildings buildhelp (awaiting Chuck's decision)

Bug #892826 reported by Hans Joachim Desserud on 2011-11-20
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Widelands media development
Undecided
Chuck Wilder
widelands
Medium
Widelands Media Developers

Bug Description

In bug 726993 the buildhelp icons where updated for small, medium and large buildings in build 16. Though I noticed that port buildings was not included in this upgrade so they still use the old icon. This icon should be updated to fit in with the others, probably rebased on the new large building icon, before build 17 is released.

Hans Joachim Desserud (hjd) wrote :
Astuur (wolfsteinmetz) wrote :

Yes, I agree, though this icon was actually quite nice already.
Even shoreline large buildings are large plots primarily and can be use for everything else.
The information that you can also build a port there comes second.
I've left out the waves. They destroy the contour of the "big" icon and don't make things any clearer.
Changed to a lighter shade blue that looks more like blue and made the anchor slightly bigger.

Astuur (wolfsteinmetz) on 2011-11-26
summary: - Need new icon for port buildings buildhelp
+ Need new icon for port buildings buildhelp (awaiting Chuck's decision)
Hans Joachim Desserud (hjd) wrote :

While the suggested icon is nice, could you try some iterations or experiment with it? Currently it looks like the anchor is stamped on the building as in addition instead of being a part of it. Some random thoughts:
- try to curve the anchor along the round wall
- have it somehow carved into the wall (though I am not sure if the main wall is tall enough)
- have the anchor more diagonally and make it lean against the wall.

To avoid any misunderstandings, these are merely suggestions, and I am fully aware they may not work. Also, if you have already picked the best out of X different sketches/ideas, I apologize in advance.

Astuur (wolfsteinmetz) wrote :

I had another close look at this, HJD, to see if I could come up with something that you might prefer,
but the truth is, that clarity of this indicator suffers, when I try to make it more "real" in any way.
And this is the one thing, I feel I must not sacrifice.
After all this has on clear function only; show where a harbout could be placed.
If this was in any way part of the "real Widelands world", I would try to place the anchor on the ground
and paint its shadow on the wall. It would also need different colors.
But it's just an indicator and part of the build help, so I think I'd best not compromize the clarity here.

Nasenbaer (nasenbaer) wrote :

Just as update: I committed an icon that fits better to the others in my last commit (port buildspace definition via editor) - however although it looks better than the previous, it not "eye biting" enough - what i try to say "if you search for the one port space between all the big spaces, you will need some time, as it looks too similiar at the moment.

Changed in widelands:
status: New → Confirmed
Changed in widelands-media:
status: New → Confirmed
assignee: nobody → Chuck Wilder (chuckw20)
Chuck Wilder (chuckw20) wrote :

Okay, I get the HINT(s). :)
I'll review this in short order and definitely resolve it by Build17-rc1. (I hope) :D

Chuck Wilder (chuckw20) wrote :

What about taking the current graphic and make it a different color (to stand out from the large building icon)? We could make the port buildings icon BLUE for example like in this attachment.

Changed in widelands:
status: Confirmed → In Progress
Changed in widelands-media:
status: Confirmed → In Progress
Nasenbaer (nasenbaer) wrote :

New graphic pushed in bzr rev. 6225 as suggested by Chuck :)

Changed in widelands-media:
status: In Progress → Fix Committed
Changed in widelands:
status: In Progress → Fix Committed
SirVer (sirver) wrote :

Released in build17-rc1.

Changed in widelands:
status: Fix Committed → Fix Released
Changed in widelands-media:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers