Buildings taken over by enemies no longer show flags with player color

Bug #886789 reported by Hans Joachim Desserud on 2011-11-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
widelands
Medium
Unassigned

Bug Description

Player A builds a military building. Once the building is occupied it will show flags in the player color to display who owns it and that it is occupied. However, if A player B takes over this building the flags are no longer shown.

I noticed this earlier today, when a player had taken over some buildings and I was sure there were soldiers in them even if they had no flags. Then I saw that in one place the player had two identical buildings next to each other, and while one of them had flags the other didn't. Turned out that the second building had been taken over from another player.

Even if player A reclaim the building, the flags does not show. I wonder if someone should look into how the flags are handled when a building change owner.

I've attached an example screenshot.

Widelands r6078

Hans Joachim Desserud (hjd) wrote :
SirVer (sirver) wrote :

i expect this to be a problem with the barrier only, or does this affect every military building?

Hans Joachim Desserud (hjd) wrote :

As far as I can see, this affect all military buildings. It was especially clear with two barbarian forts next to each other, one conquered and one built. (I don't have a screenshot of this unfortunately.)

SirVer (sirver) wrote :

I could not reproduce this. I was atlanteiden and took over buildings from a barbarian. And the flags where showing on the buildings i conquered.

Changed in widelands:
status: New → Incomplete
SirVer (sirver) wrote :

I correct myself. After the buildings have been *reconquered* by a third barbarian, they indeed did not show any flags

Changed in widelands:
status: Incomplete → Confirmed
Shevonar (shevonar) wrote :

Conquered buildings showed the unoccupied animation instead of the idle animation.

Fixed in revision 6251

Changed in widelands:
status: Confirmed → Fix Committed
SirVer (sirver) wrote :

Released in build17-rc1.

Changed in widelands:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers