Improving the load game dialog

Bug #846409 reported by Astuur on 2011-09-10
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
widelands
Wishlist
cghislai

Bug Description

The current dialog screen to load a savegame has too little information to really be useful.
(the same applies to the "load replay" screen.)
This is especially true, if you try to keep some savegames for a longer period.
Basically this forces you to load the savegame and maybe then realize what it is.
Since this window offers a lot of space, I have made an attempt to mimic an ideal "Choose your savegame" screen (attached).
I have probably overdone this a bit, as usual, and some things may be really hard and a lot of work, if ever somebody tries to code this, but it can always be "triaged"

Tags: ui Edit Tag help

Related branches

Astuur (wolfsteinmetz) wrote :
Hans Joachim Desserud (hjd) wrote :

Great mockup! Lots of good ideas. Btw, there is also a bug report on adding more details when loading a replay (bug 590528).

I like most of it, but I have some comments and suggestions for improvement in different areas:
1. Showing the map. While this could be useful, I prefer not knowing how the map looks, where my opponents are located etc. before discovering it in the game. This may be a personal preference.
2. The table with information. This is pretty much great.
2A. I assume the cell marked LAN could switch to Internet, or remain empty if it was a single player game?
2B. You could probably reorganize it a bit, because some of the cells will contain only a limited amount of text.
2C. I also think I would put the map name at the top, then the gametype information below.
2D. Have you thought about fitting in win condition somewhere?
3. The list of saved games have become slimmer. I understand this is to make room for the player information, but I wonder how this will affect save games with longer names compared to present.
4. The name column in the player info table may be a challenge. With shared kingdom I am not sure if the additional players are added together (so that you have multiple names for the same player), but it seems likely. Otherwise it looks really nice.
5. The memo column/comments. This would require some way of storing notes in Widelands, which probably won't happen at least based on bug 601405.

Lastely, a question for the programmers:
6. How much of the sketched information is actually included in a savegame and is this available through some API or similar? Is this data which is available and someone just has to present it, or does it need to be exposed to the load game menu?

Changed in widelands:
importance: Undecided → Wishlist
status: New → Confirmed
summary: - Only insufficient info on "Choose Your Savegame" dialog
+ Improving the load game dialog
Astuur (wolfsteinmetz) wrote :

Oops, yes I had the Win Condition in the sketchup, but then forgot; likewise the saving game version :)
1) Well, this is a savegame. You will not see more of the map (fog of war) than you have discovered already. (the picture is from a (no-fog game, sorry, it is misleading)
2a) Yep, that's the idea.
2b) tried that with this.
2c) I can try that, to; for this time I have merely emphasized the map a little more.
2d) see above, thanks for catching this!
3) True, but since you have to enter this while playing, I guess not many will want long titles here..... - especially since you would not need to have very descriptive titles with all this imformation available.
4) I did this a bit carefree :) No idea if that is a problem.
5) I anticipated problems here --- the coders will tell us, if that is even possible. Seemed usefull to me.

Definitely not the final attempt, just a start. I must rework the grid for one thing. I want it to be transparent and less prominent, but did not manage.

cghislai (charlyghislain) wrote :

Some more info have been commited recently

The minimap view could still be added to savegame and shown in the loading screens though.

Changed in widelands:
status: Confirmed → In Progress
assignee: nobody → cghislai (charlyghislain)
milestone: none → build18-rc1
SirVer (sirver) wrote :

Setting to fix comitted - I think pretty much that was suggested by #3 is implemented now. Astuur, if you disagree, feel free to reopen.

Changed in widelands:
status: In Progress → Fix Committed
SirVer (sirver) wrote :

Released in build-18 rc1.

Changed in widelands:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers