Multiplayer game kicked out players after being paused for a while (Broken pipe)

Bug #818823 reported by Hans Joachim Desserud on 2011-07-31
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
widelands
Low
Unassigned

Bug Description

Happened at the playday yesterday. Played multiplayer with two others, and we decided to take a 5-10min break. As host, I forced pause. A while later I asked if we should continue, but I got no reply. Shortly after that, the other players asked in IRC why they had been kicked. Then I was kicked out as well, with the error "Program received signal SIGPIPE, Broken pipe." which as far as I know means the program didn't receive any input for a while and terminated the connection. Is this a problem when games are left in pause for too long.

We played build16, but the commits doesn't seem to suggest any major changes in the network code since then.

Related branches

Hans Joachim Desserud (hjd) wrote :

Attached a backtrace. Not sure how useful it is.

Hans Joachim Desserud (hjd) wrote :

Low as this (hopefully) happens rarely.

Changed in widelands:
importance: Undecided → Low
Nasenbaer (nasenbaer) on 2012-04-26
Changed in widelands:
milestone: none → build18-rc1
assignee: nobody → Nasenbaer (nasenbaer)
status: New → Confirmed
Nasenbaer (nasenbaer) wrote :

I faced a similar problem with my dedicated server, thus I took a closer look at it and (hopefully) fixed the problem of the dedicated server as well as this one. In forced pause mode the host will now send a ping to all connected clients every 20 seconds, to keep the sockets up and running.

I will merge the branch to trunk soon.

If the problem reappears, please reopen

Changed in widelands:
status: Confirmed → Fix Committed
Nasenbaer (nasenbaer) on 2013-07-31
Changed in widelands:
assignee: Nasenbaer (nasenbaer) → nobody
SirVer (sirver) wrote :

Released in build-18 rc1.

Changed in widelands:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments