wreck sail is blue instead of white

Bug #802432 reported by ronny on 2011-06-27
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
widelands
Low
Unassigned

Bug Description

The ship wreck sail is blue but it should be white... (see attachment).

ronny (ronny-standtke) wrote :
SirVer (sirver) wrote :

what makes you believe that it should be white? It is your ship after all.

Changed in widelands:
status: New → Invalid
ronny (ronny-standtke) wrote :

> what makes you believe that it should be white?

Because in the message window "A new Headquarters shipwreck was added to your economy" a shipwreck with nice white sails was shown.

> It is your ship after all.

OK, now I understand the intention of the blue color. But I really thought it was a bug because, unfortunately, in the current implementation it looks like a blue hole punched into the screen. There are two solutions to this issue:
 1) use "playercolor=false" in tribes/empire/headquarters_shipwreck/conf (the blue flag in front of the ship wreck still shows me that it is my ship)
 2) use less aggressive colorization of the sail

I tried both proposals (see attached screenshot). The simpler and IMHO optically nicer solution is probably (1).

Changed in widelands:
status: Invalid → New
SirVer (sirver) wrote :

this is the decision of the elder of graphics. Thanks for the suggestions!

Changed in widelands:
status: New → Triaged
importance: Undecided → Low
Astuur (wolfsteinmetz) wrote :

Who knows, the "shipwreck" may not be the final picture for that purpose.
I think with a picture that allows better identification of things, it may look different.
Otherwise, I think you're right. That blue playercolor is simple to intensive and too dark.
I have said so several times before. I lighter shade of blue would also be a better contrast to black.
Cetero censeo ...

Hans Joachim Desserud (hjd) wrote :

Hi Ronny and welcome!

What about using a mostly white sail with either a vertical stripe or symbol* in playercolor? So that it gets easier to see it is the sails, but there will still be some part identifying which player it belongs to.

* I looked at http://wl.widelands.org/wiki/TheTribes/ , but the Empire doesn't seem to have a symbol at all? (Though that's a different issue)

tags: added: graphic
ronny (ronny-standtke) wrote :

Hi HaJo

> What about using a mostly white sail with either a vertical stripe or
> symbol* in playercolor? So that it gets easier to see it is the sails, but
> there will still be some part identifying which player it belongs to.

Good idea! Everything is better than the current blue hole. :-)

Chuck Wilder (chuckw20) wrote :

The sail has been modified to resemble the sail now found on the empire ships used for seafaring.
The change has been pushed in bzr rev #6356

Changed in widelands:
status: Triaged → Fix Committed
Shevonar (shevonar) on 2012-05-03
Changed in widelands:
milestone: none → build18-rc1
SirVer (sirver) wrote :

Released in build-18 rc1.

Changed in widelands:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers