Scenario does not continue in empire 2 campaign

Reported by Leif Sandstede on 2011-05-10
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
widelands
Medium
Unassigned

Bug Description

If you upgrade the Marmormine before fulfilling the other conditions the Barbarians will not be revealed, unless you build another, not upgraded, mine.

Related branches

Hans Joachim Desserud (hjd) wrote :

Hi Leif, and welcome to Launchpad!

I played a short test game right now, and experienced the same issue. I am not sure why this happens though. I thought it would already have registered that a marble mine has been built, when that objective is completed. However based on this, it seems like it checks buildings sometime later as well to see how far along the player is.

Changed in widelands:
importance: Undecided → Medium
milestone: none → build17-rc1
status: New → Confirmed
tags: added: campaign empire
summary: - cenario does not continue in empire 2 campaign
+ Scenario does not continue in empire 2 campaign
Leif Sandstede (lcsand) wrote :

I know why it happens, it continually checks if certain certain conditions are fulfilled.
In this case it checks if at least one of each mine is built. Problem is that it only checks for not upgraded marmormines. Upgraded ones are not counted. I will try to commit a patch that fixes this, once I figure out how to do that. I can already say that I like git better than bazar.

Hans Joachim Desserud (hjd) wrote :

Sounds great. :) I'm assigning this bug to you, to let others know someone are working on it.

Uploading your changes to Launchpad should be fairly straightforward. If you haven't seen them yet, you might want to take a look at https://help.launchpad.net/YourAccount/CreatingAnSSHKeyPair and https://help.launchpad.net/Code/UploadingABranch , then make a merge proposal for your branch and someone will take a look at it.

Changed in widelands:
status: Confirmed → Triaged
assignee: nobody → Leif Sandstede (widelands-sandstede)
Leif Sandstede (lcsand) wrote :

OK fix is uploaded, hope I did this correctly.

Changed in widelands:
status: Triaged → Fix Committed
Leif Sandstede (lcsand) on 2011-05-10
Changed in widelands:
status: Fix Committed → In Progress
Hans Joachim Desserud (hjd) wrote :

Seems right to me. Just please don't change the bug status to fix committed before it has been merged to trunk (though it looks like you realized that on your own).

Thanks for providing a fix, now we just have to wait for someone to take a look at it.

SirVer (sirver) wrote :

Merged in 5915. See comment for other bug 741142. Thanks for contributing!

Changed in widelands:
status: In Progress → Fix Committed
assignee: Leif Sandstede (widelands-sandstede) → nobody
SirVer (sirver) wrote :

Released in build17-rc1.

Changed in widelands:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers