Remove --double option.

Bug #756433 reported by Hans Joachim Desserud on 2011-04-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
widelands
Fix Released
Low
Shevonar

Bug Description

Steps to reproduce (assuming you have gdb installed):
1. Open a terminal (if necessary, navigate to the folder where you have compiled widelands) and run "gdb widelands".
2. Once gdb has loaded, run "run --double".

Expected results:
I get two instances of widelands, like when I run "widelands --double".

Actual result:
I get one working window, and the other seem to crash.

Every time I try it, it simply crashes, with a different backtrace each time. Specifying other parameters in gdb works fine, and widelands --double works fine outside gdb. It looks like it has problems handling both instances.

I normally rank crashes at least medium, but since this is only happening in gdb, I'm marking it low as it is unlikely to affect normal players.

Widelands bzr r6365 on Ubuntu 11.10
gdb 7.3-0ubuntu2

Related branches

Hans Joachim Desserud (hjd) wrote :

An example log. As said above, I get different backtraces each time, so this is just one of many.

Changed in widelands:
importance: Undecided → Low
description: updated
tags: added: crash
description: updated
SirVer (sirver) wrote :

Setting to incomplete for bug sweeping.

Changed in widelands:
status: New → Incomplete
Hans Joachim Desserud (hjd) wrote :

This still happens with r6941.

I don't know if the problem is that it spawns a new process and that gdb isn't too happy about that or what is causing it. I can live with a Won't Fix on this one if it is hard to solve, but currently I don't really know what the problem is...

Shevonar (shevonar) wrote :

I think the --double option should be removed. It just increases complexity and causes problems. It is as easy to start the game twice without this option.

SirVer (sirver) wrote :

I agree. And I remeber that you volunteered to do it :)

Changed in widelands:
status: Incomplete → Triaged
assignee: nobody → Shevonar (shevonar)
milestone: none → build19-rc1
summary: - Crashes when running --double in gdb
+ Remove --double option.
SirVer (sirver) on 2014-04-17
Changed in widelands:
status: Triaged → In Progress
SirVer (sirver) wrote :

Setting to incomplete for bug sweeping.

Changed in widelands:
status: In Progress → Incomplete
Hans Joachim Desserud (hjd) wrote :

Removed a while back, but the bug wasn't updated. Yay. :)

Changed in widelands:
status: Incomplete → Fix Committed
GunChleoc (gunchleoc) on 2016-10-25
Changed in widelands:
status: Fix Committed → Fix Released
GunChleoc (gunchleoc) wrote :

Fixed in build19-rc1.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments