Loading games memory usage

Bug #751836 reported by Tino on 2011-04-05
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
widelands
Medium
Unassigned

Bug Description

Perhaps related to #536317:

If you load several savegames in a row without quitting Widelands, with each load the main game process takes up ~150MB more memory. After ~10 loads Widelands just quits. I am not sure if it hits a memory limit at ~2GB, because i've 4GB of RAM on Win 7 x64, this should give every 32bit process access to max 4GB memory...

Steps to reproduce:
1.) Start widelands (build 16 rc1)
2.) Load a savegame
3.) Quit to main menu
4.) Load savegame again
5.) Repeat 3+4 as needed

Jari Hautio (jarih) wrote :

I can confirm this win7 x86 build16-rc1. Each load+quit leaks about 50-60MB memory. And you propably hit the per process memory as it's still 2GB for 32-processes on x64 windows (when using default configuration).

Hans Joachim Desserud (hjd) wrote :

Marking as confirmed based on Jari's comment.

The same issue seems to be present on Ubuntu. When loading new save games the memory usage only seemed to increase without ever reducing again.

Is this a regression, or has it just not been noticed earlier?

Changed in widelands:
importance: Undecided → Medium
status: New → Confirmed
tags: added: savegame
Nicolai Hähnle (nha) wrote :

I did some Valgrind testing which showed some memory leaks, though they weren't that big which lead me to conclude we could worry about that after build-16. Your numbers look quite different (much bigger) though, so yes, this should be investigated, and no, at least I hadn't noticed it before (to that extent).

SirVer (sirver) wrote :

I doubt this will hit many users... I usually start one game of widelands and be done than. So I agree that this is a bug, but I feel it does not validate delaying build 16. Agreed?

Hans Joachim Desserud (hjd) wrote :

Since there's been quite some work go into fixing memory leaks recently, I took a look at this to see how the situation had improved. From what I can see when reloading the same game over and over, the memory usage stays the same. I haven't done any thorough profiling, but I didn't see any noticable spikes, so if there are still leaks they are nowhere close to 100s of MB mentioned above.

This was on Ubuntu, but it would be nice if people could check with latest trunk on other platforms to verify.

Changed in widelands:
milestone: none → build18-rc1
SirVer (sirver) wrote :

Setting to incomplete - if it times out, I'll call it fixed.

Changed in widelands:
status: Confirmed → Incomplete
SirVer (sirver) on 2013-09-14
Changed in widelands:
status: Incomplete → Fix Committed
SirVer (sirver) wrote :

Released in build-18 rc1.

Changed in widelands:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers