Replace the icons for statistics and census

Bug #746645 reported by Hans Joachim Desserud on 2011-03-31
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Widelands media development
Undecided
Unassigned
widelands
Medium
Widelands Media Developers

Bug Description

The buttons for statistics/census are found in the action menu, in the tab titled "Watched". These two buttons are used to toggle building names and productivity, respectively.
Currently, the buttons display only a letter, which is the first letter in the name. When translated, the names might change and what the buttons does will be less obvious. My suggestion would be to replace the letters with some proper icons, for instance a house and the percent sign (%), with text placed on. This would indicate what kind of information the buttons offer, and how the information will be shown. Just a suggestion, feel free to ignore it, or make your own suggestions.
However, by replacing the icons, they could better communicate what they do, and would also handle translations better.

I am aware this is mostly an issue for the media team, but I posted it in both projects, as I have the impression the main widelands bug tracker is read by more people.

Hans Joachim Desserud (hjd) wrote :

A sketch, to clarify my suggestion. Colors are only for demonstration (read:picked randomly).

Changed in widelands:
importance: Undecided → Low
tags: added: graphic internationalization ui
SirVer (sirver) wrote :

I agree... those graphics are as old as the feature, I think. And I agree that english starting letters are not fitfull for the international terrain widelands is walking on.

Changed in widelands:
status: New → Confirmed
importance: Low → Medium
Chuck Wilder (chuckw20) wrote :

I attach a suggestion for substitutes. I have replaced the "C" and "S" with a pictogram showing the outline of a building with "?" to represent the census feature and "%" to represent the statistics feature. I've also attempted to mirror the coloring of the menu_watch_field.png button in the same menu.

What do you think? Acceptable? Comments please.

Astuur (wolfsteinmetz) wrote :

I think they're fine.

SirVer (sirver) on 2011-04-01
Changed in widelands:
milestone: none → build17-rc1

I have tried to make an icon for the statistics icon.

What do you think?

And a census icon as well.

If wanted I can uplaod the xcf file as well to have the possibility to make other "house" icons.

Hans Joachim Desserud (hjd) wrote :

Ah, pictogram was the word I was looking for. Thanks! :)

I think Chuck's suggestion got a bit "hollow", so I prefer fraang's one where the background is colored. However, I did like the idea of reusing the coloring from other menu elements to keep the interface consistent.

My vote so far go to fraang's suggestion, though preferably after tweaking the coloring.

Chuck Wilder (chuckw20) wrote :

fraang has a good spin on the icons, I'll admit. :) I've attached a screenshot of his current images as they appear in the menu.

Just a note: fraang, while these look okay, the dimensions of these images should be 34x34 to coincide with the other existing buttons. I'd like to see the colors tweaked a little darker to better match the "gold" arrows in the menu_watch_field button.

It looks like the icon are 33x33 pixels large. I use revision 5832 from timowi's ppa. Was that changed later?

I have made a new version of the icons. The border is cut off but this should be fixed if i resize the icon.

Ok I removed the border because it doesn't look very well and doesn't work.

Btw I have made a new icon "save game".

Hans Joachim Desserud (hjd) wrote :

Nice. Could you please use a transparent background for statistics/census instead of a black background? It would make them more consistent.

OK now without a background.

And the exit game icon also.

Hans Joachim Desserud (hjd) wrote :

For those who haven't seen it yet (though I guess most have), fraang has also posted lots of great suggestions to the UI on the forum http://wl.widelands.org/forum/topic/724/ .

When we decide which parts should be changed, how do we plan to change it? Make one large change, or pull in various details to get a more gradual change and test more as the various parts are introduced?

SirVer (sirver) wrote :

I suggest making UI adjustments in a new branch on launchpad and merge them regularly when they are in a milestone like state.

Chuck Wilder (chuckw20) wrote :

I will set up ~widelands-dev\widelands\GUI-Development in launchpad.

Shevonar (shevonar) on 2011-10-23
Changed in widelands:
assignee: nobody → Widelands Media Developers (widelands-media-dev)
Chuck Wilder (chuckw20) wrote :

Gee, it looks like I dropped the ball on this one, doesn't it? :/

I'll get on it right away.

Chuck Wilder (chuckw20) wrote :

I have added fraang's new icons for exit-game, save-game, census, and statistics with revision #6040 to the development trunk.

Changed in widelands-media:
status: New → Fix Committed
Changed in widelands:
status: Confirmed → Fix Committed
SirVer (sirver) wrote :

Released in build17-rc1.

Changed in widelands:
status: Fix Committed → Fix Released
Changed in widelands-media:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers