mouse does not work in full screen on virtual machines

Reported by LAZA on 2011-03-09
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
widelands
Medium
Unassigned

Bug Description

i tried the last development version from widelands.8-schuss.de (5882)
If i try to play in full screen mode the mouse pointer is only on the four sides but you can not move it around.
failes under

Host: Hyper-V with Windows Server 2008 R2 (64 bit)
Guest: Windows 7 (64 bit)

i think, i made this behavior before but i don't know on what machine it was...

Hans Joachim Desserud (hjd) wrote :

Woah! Thanks for reporting this.

Happens here as well. My setup is
Host: Virtualbox on Ubuntu 10.10
Guest: Arch Linux

Since that is so radically different from your setup I assume all virtual machines will be affected. Full screen works fine on the host machine, so I don't know why it doesn't work in the VM. When running as windowed it works as normal, but when I change to fullscreen, the cursor disappear and doesn't seem to do anything. Does it work when you run it in windowed mode on Windows?

As I know this has worked in the past, it is clearly a regression, though I can't pinpoint when it occurred as I mainly run WL windowed.

Changed in widelands:
importance: Undecided → Medium
status: New → Confirmed
tags: added: regression
summary: - mouse works not in virtual machines
+ mouse does not work in full screen on virtual machines
LAZA (laza74) wrote :

You are right!
I thought some time ago, at home it is an misconfiguration or something but... - i'll tried it out and again this happens!

Host: Ubuntu 10.04.2 (64 bit) with Virtualbox 3.2.12-68302~Ubuntu~lucid (from ppa)
Guest: Windows 7 SP1 (64 bit) and Windows XP SP3 (32 bit)

One of the big problems is:
Switching back to desktop you cannot kill the task neither under Lucid nor Server 2008 and the memory usage is maximum, after some minutes came the question if i want to kill the task but it still needed some minutes to end the process...

Under Server 2008 in Windows 7 is an small white spot with represents the mouse but the 'gauntlet' is only on the side and it is impossible to click on something.
In contrast to Ubuntu, where the 'gaunlet' can be moved very, very carefully and i hit after some minutes the option "full screen", killed the task and restarting the game leads to normal behaviour.

And it seems, that these problem also affects the whole OS cause clicking on something to execute (kill task, uninstall widelands) didn't work either...

In all cases the game works proper in windowed mode!

For more tests don't hesitate to ask.

Astuur (wolfsteinmetz) wrote :

It's the same on my native windows machine. (XP SP3)
This is awkward, because windowed mode in low res makes no sense on LCD Monitors if you want a more detailed (bigger) view of things.

Hans Joachim Desserud (hjd) wrote :

On a physical machine as well? That doesn't sound good. I'm cranking up the importance and we should probably look into this to make sure full screen works in build16.

From what I can tell full screen works on Ubuntu without problems. Any other operating systems affected/not affected by this?

Changed in widelands:
importance: Medium → High
milestone: none → build16-rc1
tags: added: windows
Astuur (wolfsteinmetz) wrote :

Again for Win XP SP3:
I might add, that I don't remember it ever worked - plus I have never mananged to flip from Full Screen to windowed mode or vice versa from within the game.
But I have not tried very often after the initial failure, and been away half a year.

Astuur (wolfsteinmetz) wrote :

Dammit .... what was I having in mind?
All my writing here is nonsense. I was not properly reading this report. I am very sorry. Too tired, I guess

The truth is: My mouse pointer is disabled (mouse is immovable and shown in the upper left corner of the screen)
when I play WL in full screen mode. But __not__ in the WL window (fine there), but in any other window when I ALT-TAB out.
This is independent from the "catch input" option.

WIN XP SP3

SirVer (sirver) wrote :

I cannot follow this bug report, but it is deemed important, so I need some clarification:

#6 is this the same bug or are you reporting a new one? If this is not related to a virtual machine, please open a new bug report and target it for build 16 as this is crucial.

At the rest: what exactly is not working? I assume that starting widelands inside a virtual machine in Fullscreen Mode yields a non responsive mouse cursor. It is therefore not possible to use widelands at all? If so, please test other games (wesnoth) and report back.

LAZA (laza74) wrote :

i added a picture how it looks after changing into full screen mode.

the small white point is as i said the 'real' position of the mouse pointer.
the gaunlet, which works to click, on the left side and only moves along the four lateral edges (Seitenkanten) and it is not possible to position it freely.

Astuur (wolfsteinmetz) wrote :

My comment did not really fit in here. I was misunderstanding the inititial bug description.
What I was relating to is this bug

https://bugs.launchpad.net/widelands/+bug/536559

with the possible addition that toggling FullScreen/Windowed with the "f" key never worked for me
and the "catch input" option from the configuration menu does not stop WL from catching the mouse in
full screen mode, even if set to off.

Hans Joachim Desserud (hjd) wrote :

Ok, based on the recent comments, I take it this is limited to virtual machines. Therefore I'm reverting the importance to initial settings. The reasoning is; while it should be fixed, I can live with full screen problems in virtual machines, but if it affected physical machines as well, it would be a bigger concern.

I agree that #6 sounds like it should be reported as a new bug.

>what exactly is not working?
The cursor is either invisible or stuck to one of the sides, which makes it impossible to move it to and click on any of the menu items. I have not seen the white point LAZA talks about in #8, but I may have simply missed it.
When I set Widelands to full screen, and come back to the main menu, I'm not able to do anything, so I need to force quit (ctrl+f10) and edit the widelands config-file to set fullscreen back to false.

I also tried wesnoth, which worked fine in fullscreen on the same system which has problems with widelands.

Changed in widelands:
importance: High → Medium
milestone: build16-rc1 → none
tags: removed: windows
LAZA (laza74) wrote :

appendix (sorry, fogotten):

Battle for Wesnoth 1.9.4 works for me on same system in full screen and windowed!

Host: Hyper-V with Windows Server 2008 R2 (64 bit)
Guest: Windows 7 (64 bit)

LAZA (laza74) wrote :

This problem exists still in the actual bzr 6346 under
- Ubuntu 12.04 beta2
- Windows XP SP3

Under windows i got some more problems so i was not able to play at the playday (sorry for that).
Mouse bucking/jerking and you must move very slowly to hit what you want.
Also the auto-focus function (when setting an flag, building house, ...) - when ever the build window is opened up - dos not work and you click elsewher --> a new window opens up to build there....
very annoying!

Host: Xubuntu 11.10
Virtualbox 4.1.10

Angelo Locritani (alocritani) wrote :

Fullscreen problem happens on my virtual machine,too.
It's a vmware virtual machine with lubuntu 12.04.

Angelo Locritani (alocritani) wrote :

I've tried virtual box and found that disabling mouse integration (HOST KEY+i) solves the problem. I can now play fullscreen even with opengl enabled.

using virtual box 4.1

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments