Weird green granite in the editor on Blackland maps

Bug #723113 reported by Hans Joachim Desserud on 2011-02-22
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
widelands
Low
Kiscsirke

Bug Description

Steps to reproduce
1. Start the editor
2. Select a new map (world: blackland)
2. editor->tools-resources
3. Look at the granite

Expected result:
In the other worlds granite is shown as gray/white-ish.

Actual result:
In darklands it has a green color, which looks odd. I couldn't find where the actual images were stored, so I'm not sure if it is supposed to be that way in this world.

Widelands bzr r5865 on Ubuntu 10.10

Hans Joachim Desserud (hjd) wrote :

The granite in blackland.

tags: added: editor
Changed in widelands:
importance: Undecided → Low
Chuck Wilder (chuckw20) on 2011-02-22
Changed in widelands:
status: New → Confirmed
Chuck Wilder (chuckw20) wrote :

Note in the attached screen capture from the editor that the green does not affect all of the various granite resource images, just some (maybe just one). I have searched the game graphics and have not found an image file that displays like this normally.

I'll see if I can isolate the file or files that are being rendered like this in the blacklands world and report back in a subsequent comment.

Chuck Wilder (chuckw20) wrote :

Two files match the general appearance of the image in question:
~/worlds/blackland/resources/granit_0b.png
~/worlds/blackland/resources/granit_1b.png

Chuck Wilder (chuckw20) wrote :

re:#3
Actually, only granit_1b.png is an exact match. :/ (Old eyes.)

Chuck Wilder (chuckw20) wrote :

Looks like placing a granite resource with a value of 16 or greater will yield the result. Reducing the value of a granite resource to 15 or lower results in the expected (gray) image for that value.

Chuck Wilder (chuckw20) wrote :

BTW - My tests were done in Widelands rev#5856 on Windows.

Chuck Wilder (chuckw20) wrote :

I'm not sure if this is a bug or a feature or even related to the green granite, but I've discovered something occurring when using the map editor IN ALL WORLDS:
Each of the resources have 28 image files to represent set values of 1 thru 63. These files are named as: RESOURCE_01 thru 0f and RESOURCE_13 thru 1f. In ALL worlds, files with names ending in 0c-0f and 1c-1f are NOT being displayed as expected for values greater than 26. The RESOURCE_1b.png file is being displayed instead.

If this feature is intentional, then the images which are not being displayed are extraneous and should be deleted.
If this is in fact unintentional and a bug, we seem to have a problem displaying the images for those higher values.

Chuck Wilder (chuckw20) wrote :

From the way the editor behaves when decrementing a resource value, it would seem that the resource value is NOT being incremented above 25.

Chuck Wilder (chuckw20) wrote :

To perhaps aid in troubleshooting, I have attached a screenshot of the entire collection of files that comprise the granite resource. The other resource images follow the same pattern for all worlds.
It now also seems that the files are not being displayed in the sequence suggested by the number of "balls" in their images. For example: the current progression during incrementing is ~03.png, ~04.png, ... While the graphics suggest the sequence ~03.png, ~13.png, ~04.png, ~14.png ...

Astuur (wolfsteinmetz) wrote :

Have also tried to tackle this (in vain)
We need a coder to help, I guess.

Kiscsirke (csirkeee) wrote :

The image worlds/blackland/pics/granit4.png was somehow faulty, copying over it from another world fixed the issue.

I started a more general discussion on the resource markers in the forum: http://wl.widelands.org/forum/topic/1151/

Changed in widelands:
assignee: nobody → Kiscsirke (csirkeee)
status: Confirmed → Fix Committed
Hans Joachim Desserud (hjd) wrote :

Thanks. A simple, yet elegant solution. :)

Also, nice proposal(s) in that forum post.

Changed in widelands:
milestone: none → build18-rc1
Chuck Wilder (chuckw20) wrote :

Many thanks, Andras.

SirVer (sirver) wrote :

Released in build-18 rc1.

Changed in widelands:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers