Assertion in load_animations: m_animations not empty

Bug #722789 reported by Nicolai Hähnle on 2011-02-21
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
widelands
Medium
Unassigned

Bug Description

The second time animations are loaded, an assertion is sometimes triggered:
widelands: ...src/graphic/graphic.cc:1015: void Graphic::load_animations(UI::ProgressWindow&): Assertion `m_animations.empty()' failed.

The following steps reproduce this reliably for me with r5855:
1. Start a single player game on "Crater" with default settings.
2. Exit the single player game.
3. Go to Editor -> New game
4. The assertion is triggered while the editor is loading animations

I have also seen this happen when trying to load a replay just after finishing a network game.

I'm targeting it to build16-rc1 for now, because we should definitely try to get rid of known crashes for the release...

Hans Joachim Desserud (hjd) wrote :

Happens here as well when I follow your instructions.

Changed in widelands:
status: New → Confirmed
Nicolai Hähnle (nha) wrote :

Should be fixed in r5871.

Changed in widelands:
status: Confirmed → Fix Committed
SirVer (sirver) wrote :

Released in build16-rc1

Changed in widelands:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers