Options show wrong resolution as selected if no ~/.widelands/conf exists

Bug #720338 reported by Hans Joachim Desserud on 2011-02-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
widelands
Low
Unassigned

Bug Description

To reproduce
1. Go to ~/.widelands/
2. Remove (or copy/rename) the file 'config'. This will simulate recently installed Widelands with no/default settings.
3. Start Widelands.
4. Notice the size of the window (by default set to 800x600)
5. Go to options and observe the selected resolution/size of the window. (Defaults to 640x480, which is the smallest/last option)
6. Without making any changes, click 'Apply '

Expected result:
Since no changes have been made from default, nothing should change.

Actual result:
The window is resized to 640x480 since that was selected.

It seems Widelands and options defaults to different values for resolution when none have been set in the config file. A possible solution would be to create a more detailed initial config when loading Widelands for the first time.

Widelands bzr r5828 on Ubuntu 10,10

Changed in widelands:
importance: Undecided → Low
Nasenbaer (nasenbaer) wrote :

Jepp - haven't noticed this for a while, properly because I have a config file most of the time ;)
Thanks for reporting! :)
Fixed in bzr rev. 5835

Changed in widelands:
milestone: none → build16-rc1
status: New → Fix Committed
Hans Joachim Desserud (hjd) wrote :

The way this was fixed, currently when I go into options, I get another entry below the others which is selected (800x600x16bit). First of, this is out of order with the other elements. However, when I change to any other resolution to any other, the extra option has disappeared so that you can't change back to it.

By all means, it is better than the resolution suddenly changing, but it still has some odd behaviour. Without looking at the code, is it simply inserting the alternative when no others are chosen. Is there some limitation to selecting the other elements, when no resolution have been set in the config-file? Just curious...

SirVer (sirver) wrote :

Released in build16-rc1

Changed in widelands:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers