Savegame from build 14 crash with assertion error

Bug #697375 reported by Hans Joachim Desserud on 2011-01-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
widelands
Undecided
Nicolai Hähnle

Bug Description

I think it was after bug 670959 (mainly) we got a folder for keeping older savegames, in order to test if they still be worked with the newest version. I thought about adding a savegame from build 14, in the middle of a battle.
However, when loading it in the current development version (bzr r5799) it crashes with an assertion error after a short while.
widelands: /home/user/widelands/src/logic/map.h:445: static Widelands::Map_Index Widelands::Map::get_index(const Widelands::Coords&, Widelands::X_Coordinate): Assertion `0 <= c.x' failed.
Aborted

I tried loading it in build 14 again and save a bit later, which resulted in the following error (not sure if it is related though):
 Reading Bobdata Data ... Object_Manager: ouch! remaining objects
lastserial: 5051

Game data error
bobdata: bob 183: (Carrier) reading state 3: savegame created with old broken game engine version that pushed task move without starting walk first; not fixed; try another savegame from a slightly different point in time if available; the erroneous state that this bob is in only lasts 10ms

It works fine back in build14. Feel free to ignore it since it is from an older build, but I thought I should report it anyway, especially due to the assertion error.

Hans Joachim Desserud (hjd) wrote :
Hans Joachim Desserud (hjd) wrote :
Nicolai Hähnle (nha) on 2011-01-24
Changed in widelands:
assignee: nobody → Nicolai Hähnle (nha)
Nicolai Hähnle (nha) wrote :

Fixed in r5873. I've also added the first of your savegames to the compatibility folder for future testing. Note that the second savegame won't be fixed, as the error message already explains.

Changed in widelands:
status: New → Fix Committed
Hans Joachim Desserud (hjd) wrote :

Thanks a lot.
I noticed that while it doesn't crash now, no soldiers enters the enemy building when I conquer it. Instead they go home to the other buildings. If I conquer more buildings around, and connects it to the road network, the building is filled up as expected.

While the major issue is of course dealt with and this is just an annoyance, is this intended or is it possible to change this behaviour?

Nicolai Hähnle (nha) wrote :

In principle it should be possible to fix this, but at the cost of making the fix more ugly. I was hesitant to do such bigger changes right now if it's not really necessary.

Hans Joachim Desserud (hjd) wrote :

That's ok, I was just wondering. No need for larger changes as far as I'm concerned. It did fix the crash, which was the main issue here. :)

SirVer (sirver) wrote :

Released in build16-rc1

Changed in widelands:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers