Add two multiplayer scenarios

Reported by Nasenbaer on 2010-11-10
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
widelands
Medium
Unassigned

Bug Description

This is more a reminder than a bug report:

SirVer and I talked about two multiplayer scenarios that should be shipped with Build16:

* "Island hopping" - the goal is to be the first to reach the end island - each player starts on an island and has to expand in one direction, to reach the other side of the island - once (s)he reaches the other side, (s)he hops to the next island, which means: a new headquarters will be generated on the next island. This goes on and on until the first player reaches the end island.

* "Warehouse exchange" - in an x shaped map (there should be one in trunk) the two players starting on one line of the x need to exchange a specific amount of a specific ware via warehouses build at touching borders - as the other two have the same goal, "having touching borders" will surely be a hard goal.

SirVer (sirver) wrote :

I though a bit more about the specifics

1) Island hopping: the marker for "hopping" should be finishing a sentry on a certain spot (and precisely on this spot). The new HQ will start with all the wares the current HQ has and all players can always see the whole map. Like this, the players can gain an edge by checking what is needed on the next island and concentrating on this. One could also give "prices" for finishing one island, that is if you reach an island you get a message: you arrived here first, if you finish this island you will get 5 pieces of coal while the second one gets "you arrived here second, if you finish this island, you will receive 15 pieces of coal". so various strategies could lead to success.

2) maybe we could also variate this and define precisely were the two warehouses must be build. Checking if two borders touch is maybe to costly for a scenario (but we'll try).

Hans Joachim Desserud (hjd) wrote :

Some initial feedback, first Warehouse exchange:
"in an x shaped map (there should be one in trunk)" I guess you are thinking about "Enemy at sight". One question about this scenario, though. When the goal is transporting the wares from warehouse A to warehouse B, what will happen if I start producing the ware in question right next to warehouse B? That way I wouldn't need to maintain the path from A to B, which goes against the goal of the scenario. Or will the ware in question simply be too hard/impossible to produce near warehouse B for it to be an effective strategy?

Island hopping sounds really fun. :)

Nasenbaer (nasenbaer) wrote :

@#2: When the goal is transporting the wares from warehouse A to warehouse B, what will happen if I start producing the ware in question right next to warehouse B? That way I wouldn't need to maintain the path from A to B, which goes against the goal of the scenario.

Perhaps I missunderstood you, but if |Point(A) - Point(B)| is the path between the two warehouses - you always need to maintain the path from A to B, as that is the only way the two players can exchange the wares.

Producing the ware near the warehouse might be possible, however, I don't think we should take a precious ware at all, as the much bigger rpoblem is, to hold control over the center to have the ability to exchange the wares (at least that was my initial thought).

Hans Joachim Desserud (hjd) wrote :

I'll rephrase my question a bit: is the win condition is based on having _exchanged_ a certain amount of a ware, not when you have that amount of the ware in question in your warehouse? Because if that's the case (as it seems to be), I'm the one who misunderstood it.

Nasenbaer (nasenbaer) wrote :

oh sorry, have not read this thread for quite some time. The goal is not about producing that wares, but more to keep the frontiers close together, so that an exchange can happen - so e.g. using trunks or something like that should be alright.

So actually I just came here to assign SirVer to this bug report, as the first map (for island hopping) is already in branch and the second scenario can be build upon two maps already available in trunk ("Rendezvous" and "Enemy in sight")

Changed in widelands:
assignee: nobody → SirVer (sirver)
SirVer (sirver) wrote :

Shame on me for not finishing this before the freeze. I am solely responsible for the delay of this feature and want to apologize especially to Nasenbaer which I blackmailed into making the maps just to let them sit idle forever. To my defence, the implementation is not completely straightforward as localization is not yet worked out for multiplayer scenarios.

I retarget that to build 17 for now.

Changed in widelands:
milestone: build16-rc1 → build17-rc1
Hans Joachim Desserud (hjd) wrote :

The initial version of "Island Hopping" was merged in r5965.

SirVer (sirver) wrote :

Smugglers was merged in r6011.

Changed in widelands:
status: Confirmed → Fix Committed
assignee: SirVer (sirver) → nobody
Victor Pelt (victor-pelt) wrote :

since we have a barbarian and an atlanean scenario we really need an empire one

SirVer (sirver) wrote :

I am all ears for suggestions :).

SirVer (sirver) wrote :

Released in build17-rc1.

Changed in widelands:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers