The priority buttons can be deactivated

Bug #672098 reported by Hans Joachim Desserud on 2010-11-07
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
widelands
Low
Shevonar

Bug Description

I noticed this a while back, but I still haven't found any patterns or sure-fire way to reproduce this.
1. Start a new game.
2. Create a construction site and open the construction site dialog.
3. This is the tricky part. Choose a set of the priority buttons and click on them to switch between high/medium/low priority. I usually do a combination of clicking them each in increasing/decreasing order and switching the medium with either of the others.

After doing this for a while (less than one minute) one of the buttons will become deactivated, like it is not currently chosen. However, not matter how you click on the other buttons, that button will remain deactivated, and after a while, a second button will become deactivated, and then when you click on the last one it will become deactivated as well. When I close and reopen the dialog again, it seems to be fixed, the lastly clicked button is deactivated and the others are active. They now work as intended again.

As I mentioned I haven't found any steps or pattern in my clicking that I know will trigger it, but it should be reproducible by clicking randomly for a minute or so.

Widelands bzr rev 5583 on Ubuntu 10.04.

Tags: ui Edit Tag help
tags: added: ui
Hans Joachim Desserud (hjd) wrote :

The screenshot shows deactivated priority buttons to demonstrate that while slightly hard to reproduce, it's not impossible.

SirVer (sirver) on 2010-11-07
Changed in widelands:
status: New → Confirmed
importance: Undecided → Low
David Allwicher (aber) wrote :

For me works the following. Click on high, high, default, default, low, low. Might be related to clicking again on the active preference.

Shevonar (shevonar) on 2011-09-27
Changed in widelands:
assignee: nobody → Shevonar (shevonar)
Shevonar (shevonar) wrote :

Thanks David for this hint, you were absolutely right :)
Fixed in revision 5996.

Changed in widelands:
status: Confirmed → Fix Committed
milestone: none → build17-rc1
SirVer (sirver) wrote :

Released in build17-rc1.

Changed in widelands:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers