Many menus are not repainted in OpenGL mode

Bug #649037 reported by Jens Beyer on 2010-09-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
widelands
Low
Timowi

Bug Description

In OpenGL mode, lots of the menu screens (but not all!) share the same minor problem:

Start widelands in windowed mode, move a window partly over the widelands window. Use Alt-Tab to switch back to widelands window (DO NOT MOVE THE MOUSE). The area once hidden behind the other window stays black.
Moving the mouse inside the window does force the repaint.

However, there are menu screens which are not showing this behaviour, like the Main menu.

Linux, radeon driver (not fglrx), supports OpenGL.

Related branches

Timowi (timo-wingender) wrote :

yepp menu screens are almost only redrawn if mouse cursor is moved.

Changed in widelands:
status: New → Confirmed
importance: Undecided → Low
assignee: nobody → Timowi (timo-wingender)
Timowi (timo-wingender) on 2010-10-20
Changed in widelands:
status: Confirmed → In Progress
Shevonar (shevonar) wrote :

Is this bug fixed? I couldn't reproduce it on my system (Windows 7 64bit, my opengl branch). The fix Timowi did in his branch has never got into trunk. If someone can confirm this bug, I will take over the fix.

Shevonar (shevonar) wrote :

I included the fix now although I couldn't test it, but I think Timowi did it the right way.

Shevonar (shevonar) wrote :

Merged at revision 6242

Changed in widelands:
status: In Progress → Fix Committed
milestone: none → build17-rc1
SirVer (sirver) wrote :

Released in build17-rc1.

Changed in widelands:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers