add more details to a replay

Bug #590528 reported by Lukas on 2010-06-06
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
widelands
Wishlist
Nicolai Hähnle

Bug Description

[wish]

It would be useful if you can see more details by selecting a replay file in game

name of map, e.g.

maybe number (and type) of players, and - if possible, revision this replay has been saved with.

Currently you can only see a date, a time an the global gametype (single- or multiplayer) - I'm not sure, if the time-stamp represent the beginning of the game OR the point the replay has been saved...

Nicolai Hähnle (nha) wrote :

I like your suggestions.

FYI: The time-stamp in the replay file name is the time when the game was started.

tags: added: replay ui
Changed in widelands:
importance: Undecided → Wishlist
status: New → Confirmed
Nicolai Hähnle (nha) wrote :

I'm assigning myself to get that done some time after the release of build16, as a reminder to myself.

Changed in widelands:
assignee: nobody → Nicolai Hähnle (nha)
milestone: none → build17-rc1
Hans Joachim Desserud (hjd) wrote :

Any progress on this, Nicolai?

I briefly looked a the code and I think it could be presented pretty similar to how load game does it currently.

Also, I would like to see the length of the replay, if that is possible.

Shevonar (shevonar) wrote :

Since Nicolai seems to be not active at the moment I tackled this bug. The load replay window is now very much like the load game window: you can see the same information and delete replays. If more information is wanted please add it to bug #846409, because this means a major change in the way how games are saved and loaded.
I also added some keyboard shortcuts to load replay and load game screens:
* up/down to navigate through the list
* del to delete
* enter to load / confirm deletion
* esc to go back / abort deletion

Fixed in revision 6039.

Changed in widelands:
status: Confirmed → Fix Committed
Astuur (wolfsteinmetz) wrote :

I don't know if you can still consider any of this,
 but you want to take a look here

https://bugs.launchpad.net/widelands/+bug/846409

Shevonar (shevonar) wrote :

I know this bug report and actually linked there myself ;) But this is much more difficult to implement, because ether need to load the hole game/replay just to display some information or have to change the way games are saved, so that the needed data can be preloaded. Therefore this will change together with the load game screen and probably not before build18. Sorry :/

Astuur (wolfsteinmetz) wrote :

Just asking :) Don't mean to push.
Thanks for your explanations.

Hans Joachim Desserud (hjd) wrote :

Shevonar: Thanks :) Nice to see this finally implemented.

Though, I notice only a few of my replays list a play time and the rest list 00:00. Is this a known issue or something my replays are causing somehow?

Shevonar (shevonar) wrote :

I also noticed that but I thought it is correct, since i have many replays of games that I have only started, looked at some interface improvements I did and then closed the game. So their gametime is less than 1minute which will result in 00:00.
If there are more situations which result in 00:00 gametime, that is a different bug concerning the saving process of replays.

SirVer (sirver) wrote :

I can confirm that new replays show the correct time on my box

Hans Joachim Desserud (hjd) wrote :

>I also noticed that but I thought it is correct, since i have many replays of games that I have only started, looked at some interface improvements I did and then closed the game.

Fair enough, I have a lot of replays like that as well. However, I checked with some games which I know are longer, among others from the last play day and they are also listed as 00:00. I've reported this issue as bug 886343.

SirVer (sirver) wrote :

Released in build17-rc1.

Changed in widelands:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers