write building status in a different font color for construction sites

Bug #580905 reported by Astuur on 2010-05-15
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
widelands
Wishlist
Unassigned

Bug Description

Yes, it clearly states "[some_building ] xx % built", still it would help
to see construction sites at first glance, if that very statement was written in some
different color (maybe bright green), especially as the production sites also have
percentages displayed.

Related branches

Nicolai Hähnle (nha) wrote :

I believe this would be useful not just for construction sites, but also to identify buildings that have low productivity. Of course you see the 0% or 10% or whatever, but if it were in a distinct color, it would be even more visible.

Astuur (wolfsteinmetz) wrote :

Right ... an even better idea.
We could have low ->high like traffic light (red yellow green)
But the construction site coloring is especially usefull when you upgrade a building (like fortress -> castle), because they are not easy to pinpoint immediately. Could be cyan or something....

Hans Joachim Desserud (hjd) wrote :

Actually, the progress bar in a construction site's building window is already colorcoded.
The background color depends on how many percent of the building has been constructed;
less than 15% : red
between 15%-50% : yellow
above 50% : green
Perhaps this could be reused, or altered?

My only concern is that whatever is implemented should clearly stand out from the background, not blend in. This might be a reason to keep the text yellow-only, as it is today, which gives us only one color to worry about.

Astuur (wolfsteinmetz) wrote :

True - but as it is, the yellow is bad enough in the desert world. It's hard to find a suitable color for all circumstances.
I hope that the neon type colors like magenta cyan bright green in yellow will work in most cases; I have tried that with screenshots.

Timowi (timo-wingender) on 2010-05-16
Changed in widelands:
importance: Undecided → Wishlist
tags: added: statistics ui
SirVer (sirver) wrote :

I like this idea.

Changed in widelands:
status: New → Confirmed
Hans Joachim Desserud (hjd) wrote :

Astuur: could you upload one of those screenshots?

Astuur (wolfsteinmetz) wrote :

Those were the ones I did when I checked the visibility for the soldiers' icons in different worlds.
I have not kept them, but I can can make new ones

Astuur (wolfsteinmetz) wrote :

Here a samples of each red green cyan magenta text in each of the worlds. (Modified screnshot)

Hans Joachim Desserud (hjd) wrote :

Colors and visibility are also discussed in bug 607909.

Hans Joachim Desserud (hjd) wrote :

I see this was added a while back, so construction site's percentage color will vary between red, yellow and dark green. (Not 100% sure about the green color, but it might be a compromise to allow it to stand out on all terrains.)

However, wouldn't it be nice to reuse these colors for the production status. Afterall, you usually have more buildings than construction sites, so that's what you will mainly be interested in.

Changed in widelands:
milestone: none → build18-rc1
SirVer (sirver) wrote :

I added this in mainly as a test and teaser for the new rich text rendering engine - I am personally not so very fond of the different colors. I think they add very little information but make the texts 'noisier'. So I am actually +1 for reverting to only a singular color. What do others think?

Changed in widelands:
status: Confirmed → Incomplete
Nicolai Hähnle (nha) wrote :

I would like to have different colours in the percentage productivity display for production sites. That way, one would have a very nice additional cue as to which buildings require more attention.

In that sense, what we have right now is actually the wrong way around: Having the percentages in different colours for construction sites is neat, but actually not that useful, whereas the productivity for production sites is monochrome, even though different colours there could be very useful.

Also, note that the original report was actually aiming at something else, namely at making the distinction between construction sites and finished buildings more easily visible. This is mostly an issue for buildings that are being upgraded, and having the "% built" in a different colour as well could help there.

SirVer (sirver) wrote :

All of the suggestion you make are easy to add - just reformat the string. So, I suggest trying the following:

- make color of texst for constructionsite a little different - keep the yellow, but make it less bright so that there is a visible difference to other texts in comparision.
- add red/green/yellow text to productionsites - the green has to be made brighter than it currently is for constructionsites because that is really hard to read.

Changed in widelands:
status: Incomplete → Triaged
Changed in widelands:
status: Triaged → In Progress
SirVer (sirver) on 2013-07-21
Changed in widelands:
status: In Progress → Fix Committed
Hans Joachim Desserud (hjd) wrote :

Wow, the building statuses look awesome now. The colors really add a lot. Thanks. :)

SirVer (sirver) wrote :

Released in build-18 rc1.

Changed in widelands:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers