Unable to attack castle

Bug #566970 reported by hulagutten
46
This bug affects 7 people
Affects Status Importance Assigned to Milestone
widelands
Fix Released
High
Nicolai Hähnle

Bug Description

See the white castle in the attached savegame, where their solders keep going in and out. I am also unable to attack it.

Revision history for this message
hulagutten (david-andersen) wrote :
Revision history for this message
hulagutten (david-andersen) wrote :

I forgot to say that it relates to build 15, I just downloaded it.

Revision history for this message
SirVer (sirver) wrote :

The problem is that the fortress is placed in such a way that it blocks the way for soldiers to pass through. The white player tries to attack constantly, but since his soldiers cannot get past the fortress, they stop the attack.

Nicolai, I assigned you this because you know more about the routing code. What do you think about this? This could be considered a map bug and the chokes could be made wider so that wall off becomes impossible. One could also special case big buildings and make their outer fields passable for soldiers.

Changed in widelands:
assignee: nobody → Nicolai Hähnle (nha)
status: New → Confirmed
importance: Undecided → High
milestone: none → build16-rc1
Revision history for this message
Nicolai Hähnle (nha) wrote :

So... not really sure what one could do about that.

Special-casing is not an option, because I think the equivalent problem could happen with small buildings as well.

We could change the logic that computes the field buildcaps to prevent buildings from being built where they could seal off passage. That would break some existing maps (like the one in the savegame) which would have to be fixed to match that change.

Another option would be introducing a new gameplay element that would allow one to destroy an enemy building that blocks passage like this, e.g. like Settler's catapult.

Revision history for this message
SirVer (sirver) wrote :

The catapult is a feature that I heavily disliked in settlers 2. I wouldn't want something like that in wl.

I prefer changing the buildcaps. But this feels hackish as well.

Revision history for this message
Duckblaster (duckblaster) wrote :

Perhaps allow attack from any side, as someone south of the other player has a slight advantage.

Revision history for this message
Nasenbaer (nasenbaer) wrote :

changing the buildcaps would as well mean, that you could build big buildings side by side - so that's no option for me.

To Nicolais comment: it can only happen with big buildings at the moment, which is because big buildings block some fields/nodes around as well. So can't we just change the movecaps at the fields that the bigger buildings "block"? something like a special movecap - so no streets can be build, but fugitives and other "none street walkers" can pass the "blocked" fields/nodes ?

Revision history for this message
Nasenbaer (nasenbaer) wrote :

Perhaps another alternative:
Adding special "only if no other way possible" movecaps to acid/lava terrain borders - this would not change the buildcaps behaviour and would still enable players to attack - things to change would be:
* the movecaps calculation
* the routing function (and making a difference between route finding for road building and fugitives)

Revision history for this message
Nicolai Hähnle (nha) wrote :

Hmm, procrastinated that stupid bug for too long...

Changing the buildcaps doesn't necessarily mean being able to build big buildings side by side, we could still prevent that in the same way as it was prevented before.

The problem with the first suggested movecaps variation is that it will cause people to walk through big buildings.

The problem with the last suggested movecaps variation is that I don't see how to implement it algorithmically without making a big mess. Basically, when you first encounter a lava border, the pathfinder would have to mark that field as blocked, but "openable" in the future, and then release those fields if no path has been found. It's possible, but ugly as hell. Besides, I'm not sure it actually fixes the problem everywhere (e.g. can't a similiar thing happen close to water?).

Here's where my vote is right now: Go with the buildcaps change, but *after* the release of build-16, because changing something like that could lead to all sorts of subtle problems in existing maps.

Revision history for this message
Nasenbaer (nasenbaer) wrote :

I agree.
Let's retarget this bug for build-17

SirVer (sirver)
Changed in widelands:
milestone: build16-rc1 → build17-rc1
Astuur (wolfsteinmetz)
tags: added: buildcaps gameplay
Revision history for this message
SirVer (sirver) wrote :

Not in b17 I guess.

Changed in widelands:
milestone: build17-rc1 → none
Revision history for this message
Nicolai Hähnle (nha) wrote :

Fix committed in trunk bzr6515. However, note that some maps still need to be adjusted.

Changed in widelands:
milestone: none → build18-rc1
status: Confirmed → Fix Committed
Revision history for this message
SirVer (sirver) wrote :

Released in build-18 rc1.

Changed in widelands:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Bug attachments