Segmentation fault after loading game.

Reported by Michael Uleysky on 2010-04-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
widelands
Critical
Victor Pelt

Bug Description

I loading one of my savegames (on map Riverland) and after few seconds game crashes with segmentation fault. I attach this savegame. Widelands build15 compiled from source by script build_and_run.sh. GCC 4.4.2.

Michael Uleysky (uleysky) wrote :
Victor Pelt (victor-pelt) wrote :

gcc 4.4.3 also has this issue. at first glance it crashes when a geologist tries to create a resource marker. will try to fix later today

#0 Widelands::Immovable_Descr::get_size(this = 0x0) at /var/compress/widelands/trunk/src/logic/immovable.h:88
#1 Widelands::Immovable::get_size(this = 0x6528240) at /var/compress/widelands/trunk/src/logic/immovable.cc:352
#2 Widelands::BaseImmovable::set_position(this = 0x6528240, egbase = , c = ) at /var/compress/widelands/trunk/src/logic/immovable.cc:83
#3 Widelands::Immovable::init(this = 0x6528240, egbase = ) at /var/compress/widelands/trunk/src/logic/immovable.cc:384
#4 Widelands::Immovable_Descr::create(this = 0x0, egbase = , coords = ) at /var/compress/widelands/trunk/src/logic/immovable.cc:322
#5 Widelands::Editor_Game_Base::create_immovable(this = 0x7fffffffd710, c = , idx = -1, tribe = 0x1228730) at /var/compress/widelands/trunk/src/logic/editor_game_base.cc:413
#6 Widelands::Worker::run_geologist_find(this = 0x19f6050, game = , state = ) at /var/compress/widelands/trunk/src/logic/worker.cc:901
#7 Widelands::Worker::program_update(this = 0x19f6050, game = , state = ) at /var/compress/widelands/trunk/src/logic/worker.cc:1697
#8 Widelands::Bob::do_act(this = 0x19f6050, game = ) at /var/compress/widelands/trunk/src/logic/bob.cc:225
#9 Widelands::Bob::act(this = 0x19f6050, game = , data = 2996) at /var/compress/widelands/trunk/src/logic/bob.cc:209
#10 Widelands::Cmd_Act::execute(this = 0x19b6c90, game = ) at /var/compress/widelands/trunk/src/logic/instances.cc:107
#11 Widelands::Cmd_Queue::run_queue(this = 0x7fffffffd940, interval = 42, game_time_var = @0x7fffffffd750: 16309793) at /var/compress/widelands/trunk/src/logic/cmd_queue.cc:119
#12 Widelands::Game::think(this = 0x7fffffffd710) at /var/compress/widelands/trunk/src/logic/game.cc:570
#13 Interactive_Base::think(this = 0xf5e580) at /var/compress/widelands/trunk/src/wui/interactive_base.cc:304
#14 Interactive_Player::think(this = 0xf5e580) at /var/compress/widelands/trunk/src/wui/interactive_player.cc:252
#15 UI::Panel::do_think(this = 0xf5e580) at /var/compress/widelands/trunk/src/ui_basic/panel.cc:478
#16 UI::Panel::run(this = 0xf5e580) at /var/compress/widelands/trunk/src/ui_basic/panel.cc:166
#17 Widelands::Game::run(this = 0x7fffffffd710, loader_ui = , start_game_type = Widelands::Game::Loaded) at /var/compress/widelands/trunk/src/logic/game.cc:526
#18 Widelands::Game::run_load_game(this = 0x7fffffffd710, filename = ) at /var/compress/widelands/trunk/src/logic/game.cc:403
#19 WLApplication::run(this = 0xd88b00) at /var/compress/widelands/trunk/src/wlapplication.cc:326
#20 main(argc = 2, argv = 0x7fffffffdc18) at /var/compress/widelands/trunk/src/main.cc:48

Changed in widelands:
importance: Undecided → Critical
status: New → Confirmed
assignee: nobody → Dwarik (victor-pelt)
SirVer (sirver) wrote :

segfaults on mac too.

Timowi (timo-wingender) wrote :

I found this bug. It's caused by a gamedata inconsistency. Because amount is higher than max_amount it tries to place a non existing resource indicator.

Victor Pelt (victor-pelt) wrote :

Michael did you hack the map?

Michael Uleysky (uleysky) wrote :

Sources, to be exact. I think that amount is any 32-bit signed integer.

So, It was my bug, sorry.

Changed in widelands:
status: Confirmed → Fix Committed
SirVer (sirver) wrote :

Released in build16-rc1

Changed in widelands:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers