It should be possible to stop delivery of wares and to drop wares in production sites

Bug #536570 reported by astuur on 2009-07-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
widelands
Wishlist
Unassigned

Bug Description

The delivery of raw materials to any production site should stop immediately as soon as the building itsself is stopped.
Otherwise raw materials that you may urgently need elsewhere may disappear in the productionsites's interial storage and be lost for other purposes. Currently there is no way to get it back.

Raul Ferriz (raul.ferriz) wrote :

Another aproach could be : allow to drop materials from stopped production sites.

SirVer (sirver) wrote :

I think it would be best to have something that existed in settlers 2 and that timowi is currently implementing for warehouses: stop delivery of ware, drop ware. This is not really about stopped or non stopped.

I change the title of the bug assuming that such a feature scratches the itch astuur had. Astuur, please change if this is not what you intended.

Changed in widelands:
status: New → Confirmed
summary: - Stop delivery at once in stopped production sites
+ It should be possible to stop delivery of wares and to drop wares in
+ production sites
Changed in widelands:
importance: Undecided → Wishlist
SirVer (sirver) wrote :

See also blueprint stocklevels

Astuur (wolfsteinmetz) wrote :

In fact any method to re-gain raw material from a production site is fine - and probably a more universal and better solution
The comprehensive stocklavels approach covers all of these situations (and a lot besides).

SirVer (sirver) on 2011-10-08
Changed in widelands:
assignee: nobody → SirVer (sirver)
milestone: none → build17-rc1
SirVer (sirver) wrote :

Fixed in r6022. But see bug 871401.

Changed in widelands:
status: Confirmed → Fix Committed
assignee: SirVer (sirver) → nobody
SirVer (sirver) wrote :

Released in build17-rc1.

Changed in widelands:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints