Animated Citizens/Carrierers

Bug #536505 reported by ionbulgar
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Widelands media development
Fix Released
Wishlist
Unassigned
widelands
Fix Released
Wishlist
Unassigned

Bug Description

It would be nice to see the Carriers even when they don't have anything to do, that they move a bit (similar with the animals around). For example they could sit down if they did nothing for more then 5 minute; maybe dance a bit, play with a yoyo or just move so they don't look like a piece of furniture. I know this is more about graphics then anything but it would add quite much to the atmosphere of the game.
Cheers, Ion.

Tags: gamedata flair

Related branches

Changed in widelands:
importance: Undecided → Wishlist
tags: added: gamedata
Revision history for this message
SirVer (sirver) wrote :

This needs new graphics and support in the engine. The second thing is likely implementable in < 1h

tags: added: flair
Changed in widelands:
status: New → Confirmed
Changed in widelands-media:
status: New → Confirmed
importance: Undecided → Wishlist
Revision history for this message
Samith Sandanayake (samithdisal) wrote :

media will not be designed untill the graphic engine is supporting it :|

Revision history for this message
SirVer (sirver) wrote :

I suggest the other way around: graphics are harder to do than to implement this. Bring animations and we will bring code ;)

Revision history for this message
Alexia Death (alexiade) wrote :

Well, it's near impossible to test an animation properly , if the engine does not support it. But since SirVer says its easy... It should be an "idle" animation for a carrier then?

Revision history for this message
SirVer (sirver) wrote :

I added a bug report for the engine. We will deliver this in build16-rc1. See bug 553180

Changed in widelands:
milestone: none → build16-rc1
Revision history for this message
Victor Pelt (victor-pelt) wrote :

blueprint added. please discuss

Revision history for this message
Victor Pelt (victor-pelt) wrote :
Revision history for this message
SirVer (sirver) wrote :

amazing chuck, you are really churning through those right now ;)

Revision history for this message
Chuck Wilder (chuckw20) wrote : Re: [Bug 536505] Re: Animated Citizens/Carrierers

Thanks.

I'm working my way to the Atlanteans. Figured I'd best complete the most
visible of the older tribes first.

I can change priorities if you wish.

Cheers,
Chuck

On Fri, Apr 23, 2010 at 3:38 AM, SirVer <email address hidden> wrote:

> amazing chuck, you are really churning through those right now ;)
>
> --
> Animated Citizens/Carrierers
> https://bugs.launchpad.net/bugs/536505
> You received this bug notification because you are a member of Widelands
> Media Developers, which is subscribed to Widelands media development.
>
> Status in Widelands: Confirmed
> Status in Widelands media development: Confirmed
>
> Bug description:
> It would be nice to see the Carriers even when they don't have anything to
> do, that they move a bit (similar with the animals around). For example they
> could sit down if they did nothing for more then 5 minute; maybe dance a
> bit, play with a yoyo or just move so they don't look like a piece of
> furniture. I know this is more about graphics then anything but it would add
> quite much to the atmosphere of the game.
> Cheers, Ion.
>
>
>

Chuck Wilder (chuckw20)
Changed in widelands-media:
status: Confirmed → In Progress
Changed in widelands:
status: Confirmed → In Progress
Revision history for this message
Chuck Wilder (chuckw20) wrote :

Last remaining worker animated in trunk rev #5583!

Changed in widelands-media:
status: In Progress → Fix Committed
Changed in widelands:
status: In Progress → Fix Committed
Revision history for this message
SirVer (sirver) wrote :

Released in build16-rc1

Changed in widelands:
status: Fix Committed → Fix Released
Changed in widelands-media:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers