Downgrade skilled workers when possible

Bug #536482 reported by bedouin on 2007-07-01
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
widelands
Medium
Unassigned

Bug Description

Since rev2330, skilled workers will be used when unskilled ones are not available (eg. miner vs. master miner vs. chief miner). When an unskilled worker becomes available later, the skilled worker should be replaced with the unskilled one for maximum efficiency.

See also:
Mailing list thread "Re: [Widelands-public] [Widelands-cvs] SF.net SVN: widelands: [2330] trunk/src"

bedouin (bedouin-users) wrote :

Logged In: YES
user_id=20557
Originator: YES

See also feature request #1212248

SirVer (sirver) wrote :

The feature request linked is a sf.net link. On launchpad it is bug #536429.

Changed in widelands:
status: New → Confirmed
importance: Undecided → Medium
Denis Bernard (db47h) wrote :

This one is quite painful. Bug #536429 fixed only half of the problem.

_aD (ad-simplypeachy) on 2012-07-16
tags: added: worker
Nicolai Hähnle (nha) wrote :

I believe we should consider this fixed now that workers can be ejected.

Changed in widelands:
milestone: none → build18-rc1
status: Confirmed → Fix Committed
_aD (ad-simplypeachy) wrote :

I just came across this bugged behaviour:
Two Empire mines present.
Level 2 mine has one Miner, one position for Master Miner vacant with no-one available.
Level 1 mine has Master Miner.

I ejected the Master Miner. He went to the level 2 mine which then began work. The level 1 mine was left vacant. I have no miners of any level in stock, but I have six picks. HQ is not generating a miner.

_aD (ad-simplypeachy) wrote :

One other relevant comment: I marked all wares for the mine to be removed, but they are not being taken out.

Nicolai Hähnle (nha) wrote :

This seems to be a separate bug. Could you open one? In any case, it would be really good to have a replay available for analysis.

SirVer (sirver) wrote :

Released in build-18 rc1.

Changed in widelands:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers