macOS: 2 builds for Release

Bug #1817607 reported by Toni Förster
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
widelands
Fix Released
Wishlist
Unassigned

Bug Description

This isn't really a bug. I sometimes use SirVers daily builds for testing. The problem with those builds is, they have OSX 10.7 as minimum build target and therefore do not support Retina Displays. The result is very fuzzy/jagged text in the menus.

I currently build Widelands on macOS 10.14 and have set the minimum target to macOS 10.9, here the text is much sharper.

So we would need two final builds. One for 10.9 and onwards and one for the older versions of macOS.

Tags: macos

Related branches

Revision history for this message
SirVer (sirver) wrote : Re: [Bug 1817607] [NEW] macOS: 2 builds for Release

Is it time to retire support for Mac OS < 10.9?

> Am 25.02.2019 um 18:52 schrieb Toni Förster <email address hidden>:
>
> Public bug reported:
>
> This isn't really a bug. I sometimes use SirVers daily builds for
> testing. The problem with those builds is, they have OSX 10.7 as minimum
> build target and therefore do not support Retina Displays. The result is
> very fuzzy/jagged text in the menus.
>
> I currently build Widelands on macOS 10.14 and have set the minimum
> target to macOS 10.9, here the text is much sharper.
>
> So we would need two final builds. One for 10.9 and onwards and one for
> the older versions of macOS.
>
> ** Affects: widelands
> Importance: Wishlist
> Status: New
>
> --
> You received this bug notification because you are subscribed to
> widelands.
> https://bugs.launchpad.net/bugs/1817607
>
> Title:
> macOS: 2 builds for Release
>
> Status in widelands:
> New
>
> Bug description:
> This isn't really a bug. I sometimes use SirVers daily builds for
> testing. The problem with those builds is, they have OSX 10.7 as
> minimum build target and therefore do not support Retina Displays. The
> result is very fuzzy/jagged text in the menus.
>
> I currently build Widelands on macOS 10.14 and have set the minimum
> target to macOS 10.9, here the text is much sharper.
>
> So we would need two final builds. One for 10.9 and onwards and one
> for the older versions of macOS.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/widelands/+bug/1817607/+subscriptions

Revision history for this message
GunChleoc (gunchleoc) wrote :

I am not familiar with MacOS. Our third user is Klaus. If he's OK with it too, let's do it and see if anybody complains.

tags: added: macos
Revision history for this message
kaputtnik (franku) wrote :

Is this part of the widelands code or part of building on a specific OS?

Toni, maybe you can provide other builds for macOS? Adapt the wikipage (https://wl.widelands.org/wiki/Download/#macos_1) to fit with your changes.

Revision history for this message
SirVer (sirver) wrote :

> Is this part of the widelands code or part of building on a specific OS?

Yes :). It is hard to build for an older Mac OS Version on newer Mac OS Version and it will require code changes to bake in the mac version we want to build. But not a ton.

Mac OS X 10.7 was released on Jul 1 2011, i.e. 7 years ago.
Mac OS X 10.9 was released on Oct 22 2013, i.e. 5 years ago.

If we require 10.9 we will loose mac users that have macs that are older than 7 years. Are we fine with this, Gun?

I currently favor the approach of having two Mac builds, i.e. Toni's for 10.9 and later and mine for 10.7, however that might be confusing to non-technical Mac OS users (of there are a ton).

Toni, can you also share your current build procedure? I can probably adapt the nightly build to also run on my laptop which is quite current. So I could produce two different releases in the nightlies.

Revision history for this message
Toni Förster (stonerl) wrote :

I'm currently making some changes in the build.sh script. When I'm finished, I'll make a merge request.

GunChleoc (gunchleoc)
Changed in widelands:
status: New → Fix Committed
Revision history for this message
GunChleoc (gunchleoc) wrote :

Fixed in build20-rc1

Changed in widelands:
status: Fix Committed → Fix Released
Revision history for this message
SirVer (sirver) wrote :

I am now building two versions of the nightlies: The first one is the one we always had (>= 10.7), the other one is building on the work of Toni and builds on my laptop for >= 10.9. Both seem to work fine on my 10.13 laptops, with one caveat:

The >= 10.9 has no sound playing. I have the same issue for the build 20-rc1 release that Toni build. I made a new bug report for this, see bug 1825925.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers