scrolling not possible with arrow keys

Bug #1808169 reported by Toni Förster
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
widelands
Fix Released
Undecided
Unassigned

Bug Description

I'm runnig build 8937 on macOS 10.14.2. The bug is as follows:

As soon as I press one of the menu buttons, it is not possible to scroll using the arrow keys anymore. The only way the get scrolling working again, is to build a building or flag post. This happens on the Editor as well.

When using the keyboard shortcuts (m, space, o, F1, etc) instead of the buttons the bug does not appear.

Tags: ui

Related branches

Revision history for this message
Benedikt Straub (nordfriese) wrote :

I can confirm this. A non-critical but very very annoying bug that occurs quite frequently, perhaps we should target it for build 20…

It´s also possible to re-enable scrolling by opening and closing a window using the shortcut (e.g. press 'N' twice). Looks like the focus is not transferred correctly sometimes.

Changed in widelands:
status: New → Confirmed
Revision history for this message
Toni Förster (stonerl) wrote :

Does not work for all shortcuts though.

Using these shortcuts it does enable scrolling again:

- n
- ENTER
- e

These shortcuts do not work:

- m
- i
- o
- b
- F1
- SPACE
- CTRL+0

... and I guess all the others also do not, but haven't tested.

Notabilis (notabilis27)
Changed in widelands:
status: Confirmed → In Progress
assignee: nobody → Notabilis (notabilis27)
Revision history for this message
Toni Förster (stonerl) wrote :

I tested the linked branch.

Now the arrow keys work. But when the following windows are open they don't.

- n (Message Window)
- e (Seafaring Stats)
- ENTER (Chat Window)

The windows need to be closed first. All other windows can be opened while using the arrow key.

Revision history for this message
Toni Förster (stonerl) wrote :

I meant "... can stay open..." not "...be opened..."

Revision history for this message
Toni Förster (stonerl) wrote :

I'm stupid :( These 3 Windows need focus for the lists...

Revision history for this message
Notabilis (notabilis27) wrote :

Thanks for testing! I now requested a merge, which I haven't done before since I still wanted to understand the behavior of the code.
Thanks also for testing the bug and mentioning the keys in #2, that helped a lot figuring this out. And you are right that the three windows are needing the keyboard focus. The other dialogs requested it as well, but didn't provided any action for the grabbed keys, leading to the annoying behavior.

GunChleoc (gunchleoc)
Changed in widelands:
milestone: none → build20-rc1
status: In Progress → Fix Committed
tags: added: ui
Revision history for this message
GunChleoc (gunchleoc) wrote :

Fixed in build20-rc1

Changed in widelands:
assignee: Notabilis (notabilis27) → nobody
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers