Flatpak package

Bug #1807625 reported by scx on 2018-12-10
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
widelands
Fix Released
Undecided
Unassigned

Bug Description

I created a flatpak package for Widelands.
https://github.com/scx/widelands-flatpak

I am in the process of submitting it to the Flathub repo.
https://github.com/flathub/flathub/pull/394
https://github.com/scx/flathub/tree/org.widelands.widelands

It would be nice if Widelands Team decided to participate in the further development of this flatpak package.

Due to the Flathub requirements, I had to make some changes to the AppData file:
1. change value of the "id" tag from "org.widelands.widelands.desktop" to "org.widelands.widelands" - https://github.com/flathub/flathub/wiki/AppData-Guidelines#id
2. add "provides" tag - https://www.freedesktop.org/software/appstream/docs/chap-Metadata.html#tag-provides
3. add "launchable" tag - https://www.freedesktop.org/software/appstream/docs/chap-Metadata.html#tag-launchable

These changes should be upstreamed: https://code.launchpad.net/~the-scx/widelands/build19-flatpak
- Fix compilation against ICU 61 - https://bazaar.launchpad.net/~the-scx/widelands/build19-flatpak/revision/8150
- Fix AppData file - https://bazaar.launchpad.net/~the-scx/widelands/build19-flatpak/revision/8151

I prepared analogous changes to the trunk branch: https://code.launchpad.net/~the-scx/widelands/trunk-flatpak
- Additionally, I have removed the invalid "icon" tag: https://bazaar.launchpad.net/~the-scx/widelands/trunk-flatpak/revision/8939

You should also consider renaming the AppData file from "widelands.appdata.xml" to "org.widelands.widelands.appdata.xml". The same applies to the icons: data/images/logos/wl-ico-*.png
This is not required, but I have been forced by Flathub maintainers to at least try to convince you to do it.

I will be grateful for any comments on this. It would be nice if someone from the Widelands Team would speak here:
https://github.com/flathub/flathub/pull/394#pullrequestreview-171796328

BTW, you should also look at this: https://github.com/hughsie/appstream-glib/issues/270

scx (the-scx) wrote :
scx (the-scx) wrote :
scx (the-scx) wrote :
kaputtnik (franku) wrote :

Hi scx, thanks for your work to get widelands into the flatpak repo :-)

I am not familiar with the changes to appdata, but there were some issues with it in the past. Please be patient and wait for GunChleoc... but it may take some time (weeks) until an answer arrives here.

scx (the-scx) wrote :

I decided to change the Application ID to "org.widelands.Widelands".
This convention is used by many other programs, especially on Flathub, e.g. com.teeworlds.Teeworlds, org.freeciv.Freeciv, org.openttd.OpenTTD, org.sauerbraten.Sauerbraten, org.wesnoth.Wesnoth, org.xonotic.Xonotic, ws.openarena.OpenArena, etc.

New Pull Request (App Submission):
https://github.com/flathub/flathub/pull/850

See also:
https://paste.ubuntu.com/p/ng6Qz2PgMT/

GunChleoc (gunchleoc) wrote :

Thanks for taking this on! :)

The changes look OK to me. I don't want to mess with the "invalid" icon tag though, because it was added by the Debian folks so that we could have Widelands in the Debian software centers. I have spent many days on this dratted file and I am afraid to touch it again while it's working.

Can you please create a merge request against trunk here, so that we can see a diff?

Changed in widelands:
status: New → Confirmed
GunChleoc (gunchleoc) wrote :

I have merged the trunk version. Since Build 20 will be ready in a few weeks, I did not merge the Build 19 version.

Changed in widelands:
milestone: none → build20-rc1
status: Confirmed → Fix Committed
GunChleoc (gunchleoc) wrote :

Fixed in build20-rc1

Changed in widelands:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers