Some windows machines complain about missing libreadline7.dll

Bug #1769426 reported by GunChleoc on 2018-05-06
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
widelands
Undecided
Unassigned

Bug Description

Reported on the forum:

https://wl.widelands.org/forum/topic/4245/

https://wl.widelands.org/forum/topic/4288/?page=1#post-25325

When I start Widelands, I get message (translated from Polish):

> The program can't be run, because on this computer there is no file libreadline7.dll. Try reinstalling the program to solve the problem.

After confirming the message, it happen again and after that Widelands starts with no problem. I hope it is not the issue and it is solved in current dev version.

Related branches

GunChleoc (gunchleoc) on 2018-07-12
description: updated
Tino (tino79) wrote :

I'll look into this. Will have to investigate:
- Which windows versions are affected?
- Which builds (appveyor, my builds) (x86/x64) are affected?

GunChleoc (gunchleoc) wrote :

So far, this has only been reported for AppVeyor, Configuration: Release; Platform: x64.

One system was Windows 7, the other system unknown

Tino (tino79) on 2018-09-18
Changed in widelands:
status: New → Incomplete
assignee: Tino (tino79) → nobody
GunChleoc (gunchleoc) wrote :

Some more info:

> The game still fails when it starts.
> The error is as follows.
> I do not know the exact English message because it is translated contents.
>
> This message occurs twice before the main screen appears.
>
> ---------------------------
> Widelands master-3961_Debug_x86 (Debug): widelands.exe - System error
> ---------------------------
> The program can't start because libreadline7.dll is missing from you
> computer. Please reinstall the program to fix this problem
> ---------------------------
> Confirm

Tino (tino79) wrote :

Where is the info in #3 from? Which OS?

Still not sure, what and where to test. Now it is x86 Debug, before it was x64 Release.

GunChleoc (gunchleoc) wrote :

I noticed that the iss file does not include a libreadline. Maybe we should just add it?

GunChleoc (gunchleoc) wrote :

Windows version for #3 is Win7 32bit.

kaputtnik (franku) wrote :

I think this bug is fixed, because libreadline was added.

Feel free to reopen this again.

Changed in widelands:
status: Incomplete → Fix Committed
GunChleoc (gunchleoc) wrote :

My e-mail tester has gotten back to me now and has confirmed that this is fixed :)

GunChleoc (gunchleoc) wrote :

Fixed in build20-rc1

Changed in widelands:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers