Suggestion - Change cursor when in road building mode

Bug #1731523 reported by Luitzen on 2017-11-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Widelands media development
Fix Released
Undecided
Unassigned
widelands
Fix Released
Wishlist
Unassigned

Bug Description

Sometime you're in road building mode without realizing it, causing unexpected behaviour. The solution would be to change the mouse pointer when you're in road building mode. I attached an example that could be used.

Luitzen (luitzen) wrote :
GunChleoc (gunchleoc) on 2017-11-10
tags: added: ui
Changed in widelands:
importance: Undecided → Wishlist
status: New → Confirmed
tags: added: lowhangingfruit
GunChleoc (gunchleoc) wrote :

I have attached a branch with this change. I don't think that the new graphics integrate visually - I don't like the standard cursor either though.

Would you like to play some more with the graphics? Let me know if you need a Windows build of this branch.

kaputtnik (franku) wrote :

What about using /images/wui/overlays/set_flag.png for this? Or something based upon this image?

BTW: I have noticed there are two identical images in /data/images/wui/fieldaction/:

menu_tab_buildroad.png
menu_build_road.png

GunChleoc (gunchleoc) wrote :
kaputtnik (franku) wrote :

I am fiddling with some images...

Attached the current state of mouse pointer. I am not really satisfied, but the direction is imho fine.

kaputtnik (franku) wrote :

During testing i noticed the Tooltip "Build Road" for the tab. IMHO it should be renamed into "Flag Actions" or similar.

kaputtnik (franku) wrote :

A new one with no mouse pointer in the way...

GunChleoc (gunchleoc) wrote :

I'm having trouble parsing the new mouse pointer icon - I don't know what it's supposed to represent. Maybe it just needs more work before it becomes clear.

I like the concept for the new button icon - Let's have it as the tab icon, and another one with just a road for the build road action?

As for the tab tooltip, I'm in favor of "Flags & Roads".

kaputtnik (franku) wrote :

The problem with the mouse pointer a fixed hotspot. When reading the code i think the hotspot is at 3,7. So we need something which looks like pointing to 3,7. But you are right, the mouse pointer isn't good.

> I like the concept for the new button icon - Let's have it as the tab icon, and another one with just a road for the build road action?

The idea behind my suggestion is: Road building is done by placing flags. It isn't possible to build a road without flags. More over with the button it is possible to place only flags without building a road. So in my mind the Flag is the important image for the button. Hm.. maybe using the same image for button and mouse pointer would be good... have to fiddle...

The Tab instead is used to give access to actions related to a flag. Beside giving the possibility to connect flags with roads, the tab gives also other possibilities, e.g. Sending a geologist. So in my mind the Tab image should reflect the actions a user accesses when clicking on the tab. Placing Flags (with or without building a road) is just one possibility. Using only a road as tab icon doesn't fit imho (beside i believe this would result in the same problem as you had with my mouse pointer suggestion ;-) )

kaputtnik (franku) on 2017-11-27
Changed in widelands-media:
status: New → In Progress
assignee: nobody → kaputtnik (franku)
Changed in widelands:
assignee: nobody → kaputtnik (franku)
status: Confirmed → In Progress
kaputtnik (franku) wrote :

A new one. I used the same gray coloring as used by the normal hand pointer. I think all pointer types should use the same coloring...

The button for starting road building is same image, but colored.

To test against grayish terrains i tried to make a new map, but during saving the editor crashes... Bug report will follow.

GunChleoc (gunchleoc) wrote :

Much better :)

I'm not so sure about the target symbol though, The target is the fsel cross, ans it will jump from node to node, so it will not always be in the same direction as the target in the cursor.

What would a mirrored version of the tab icon look like?

kaputtnik (franku) wrote :

Just encountered that there is another button which needs changing: menu_remove_way.png for removing a road without removing a flag. I am working on this.

kaputtnik (franku) wrote :

New screenshots.

Regarding the target symbol please check it in a real game. I think it helps targeting a real position. It is the same behavior as with the hand pointer.

Branch updated reflecting the screenshots.

I am adding the current state of the field selectors to this bug report as wished on the forums.

GunChleoc (gunchleoc) wrote :

#13 I attached a screenshot illustrating my position.

Maybe the difference to the hand is that it's an established icon, whereas the road building icon is not. I also think that the target symbol makes it very busy - something simpler like just a bare road shape would be better IMHO.

kaputtnik (franku) wrote :

I understand your problem :-) Nevertheless i think the target is fine. Maybe because of my workflow of building roads by clicking to the 'steepness' symbols of the overlay. Without the target its unclear where the mouse points to (where the hotspot is).

Also i think the mouse pointer should have a certain weight.

Maybe Fraang have a better idea.

GunChleoc (gunchleoc) wrote :

The semantics of the mouse cursor should always be "this is where my mouse is right now" - we have he fsel symbol to tell you which node gets selected.

Alternatively, we could change the fsel symbol instead of the mouse cursor, from a cross to a little blue flag`?

kaputtnik (franku) wrote :

> Alternatively, we could change the fsel symbol instead of the mouse cursor, from a cross to a little blue flag`?

I think that would be the best :-)

Currently there is no code to change the fsel symbol in a game, isn't it?

GunChleoc (gunchleoc) wrote :

There is now - I have pushed a change to the attached branch :)

kaputtnik (franku) wrote :

It's really better to change the fsel graphics... please remove the roadbuilding cursor :-)

There is also a small problem with the hotspot, but the hotspot is just the center of the fsel graphics, so this can easily be circumvented.

I've made some other graphics, by combining normal fsel with a flag. Attached some examples. The images of the last two rows show a slightly taller fsel. The flag has also those blackish border like we have now for.

GunChleoc (gunchleoc) wrote :

I like the bottom ones. I think the road icons are also good to go - add everything to the branch, please?

I'll then remove the superfluous mouse cursor.

kaputtnik (franku) wrote :

Done. I have pushed two branches. The second has an additional flag on the tab, and i used base images with size 34x34.

Choose what you like. If you prefer r8490 over r8491, just uncommit the changes.

GunChleoc (gunchleoc) wrote :

I liked the first version better, the flag was hard to read on the second version.

I have also swapped the tab icon, so the category has both a road and flags in it, and the road building icon just the road. This means that the delete road symbol not has some extra flags on it that need to go for consistency.

kaputtnik (franku) wrote :

I like it :-)

OK here the updated field selector files.

GunChleoc (gunchleoc) wrote :

Thanks, I have added them to the branch. We still need to add the .blend files to the Media repository.

@kaputtnik, could you please edit the "delete road" symbol as I mentioned in #23? We could test and merge this branch then.

kaputtnik (franku) wrote :

Done. Added the xcf file also to the media-repo. Will try to add the blend files also.

I am not sure how to merge this since there is no merge proposal. Shall i merge it into trunk directly without using bunnybot?

kaputtnik (franku) on 2018-01-05
Changed in widelands-media:
status: In Progress → Fix Committed
kaputtnik (franku) wrote :

Merged the branch the usual way.

Thanks Florian for this new great images :-)

Changed in widelands:
status: In Progress → Fix Committed
assignee: kaputtnik (franku) → nobody
Changed in widelands-media:
assignee: kaputtnik (franku) → nobody
GunChleoc (gunchleoc) wrote :

We still need to add the blend files to the media repository.

Changed in widelands-media:
status: Fix Committed → Confirmed
kaputtnik (franku) wrote :

I did that already http://bazaar.launchpad.net/~widelands-media-dev/widelands-media/widelands-media/revision/207

Extracted them from the zip file and put them into the media-repo including fraangs licenses

Changed in widelands-media:
status: Confirmed → Fix Committed
Changed in widelands:
milestone: none → build20-rc1
GunChleoc (gunchleoc) wrote :

Cool, thanks! :)

I added a blend file for the road building field selector and upload the new ZIP archive here.

GunChleoc (gunchleoc) on 2018-01-10
Changed in widelands:
status: Fix Committed → In Progress
kaputtnik (franku) on 2018-01-23
Changed in widelands:
status: In Progress → Fix Committed
GunChleoc (gunchleoc) wrote :

Fixed in build20-rc1

Changed in widelands:
status: Fix Committed → Fix Released
Changed in widelands-media:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers