Cleanup after move to boost.net

Bug #1697192 reported by Klaus Halfmann on 2017-06-10
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
widelands
Fix Released
Medium
Unassigned

Bug Description

After the move to boost.asio in https://code.launchpad.net/~widelands-dev/widelands/net-boost-asio
we must cleanup up some dependencies:
 * MacPort muts not depend on SDL.net any longer
 * what about debian and similar packages
 * what else can be dropped / removed now?

Related branches

I ran

    grep "SDL.net" * -ri --exclude-dir build --exclude-dir po --exclude-dir data

and came up empty, so I think we're mostly in the clear.

I found libsdl2-net-dev in debian/control though - will ping hjd.

I already added a note to https://wl.widelands.org/wiki/Building%20Widelands/ that SDL.net is for Build19 and older.

tags: added: cleanups network
summary: - Clenaup after move to boos.net
+ Clenaup after move to boost.net
Changed in widelands:
assignee: nobody → Hans Joachim Desserud (hjd)
Klaus Halfmann (klaus-halfmann) wrote :

Just after writing the Bug the Launnchap Buildsystem has a Problem:

...
CMake Error at /usr/share/cmake-2.8/Modules/FindBoost.cmake:1131 (message):
  Unable to find the requested Boost libraries.

  Boost version: 1.54.0

  Boost include path: /usr/include

  Could not find the following Boost libraries:

          boost_system

  Some (but not all) of the required Boost libraries were found. You may
  need to install these additional Boost libraries. Alternatively, set
  BOOST_LIBRARYDIR to the directory containing Boost libraries or BOOST_ROOT
  to the location of Boost.
...

how can/must we fix this?

Hans Joachim Desserud (hjd) wrote :

Just saw this.

I haven't been following the network branch, but I can review the build dependencies.

The cause of the build failure in the PPAs seems to be that it now requires more boost libraries when building. I'll push a branch which should fix the immediate build failures now, and look more into the dependencies tomorrow.

Changed in widelands:
importance: Undecided → Medium
milestone: none → build20-rc1
status: New → In Progress
tags: added: ftbfs
GunChleoc (gunchleoc) wrote :

I'm now also getting a compiler warning - I was creating a release build:

[ 53%] Building CXX object src/network/CMakeFiles/network.dir/netclient.cc.o
/home/bratzbert/sources/widelands/background_images/src/network/netclient.cc: In member function ‘void NetClient::send(const SendPacket&)’:
/home/bratzbert/sources/widelands/background_images/src/network/netclient.cc:71:9: warning: unused variable ‘written’ [-Wunused-variable]
  size_t written =
         ^
[ 53%] Building CXX object src/network/CMakeFiles/network.dir/nethost.cc.o
/home/bratzbert/sources/widelands/background_images/src/network/nethost.cc: In member function ‘void NetHost::send(NetHost::ConnectionId, const SendPacket&)’:
/home/bratzbert/sources/widelands/background_images/src/network/nethost.cc:173:10: warning: unused variable ‘written’ [-Wunused-variable]
   size_t written = boost::asio::write(

Klaus Halfmann (klaus-halfmann) wrote :

Yep, I see other warnings, too (overriden methods not virtual or such).
Onc you create a branch I will try tot fix those.

Klaus Halfmann (klaus-halfmann) wrote :

OK for the MacPort -devel build,
as of: http://wl.widelands.org/forum/topic/2627/

mut care for final again one we release r20.

summary: - Clenaup after move to boost.net
+ Cleanup after move to boost.net
Hans Joachim Desserud (hjd) wrote :

Should build successfully and with the required build dependencies once the attached branch has landed. I might slightly tweak the dependencies used by travis so that they are aligned more with the PPA, as mentioned in the MP. It will be a couple of days before I can work on a patch for this, but if anyone else wish to pick it up, I can review the changes :)

GunChleoc (gunchleoc) on 2017-06-27
Changed in widelands:
status: In Progress → Fix Committed
assignee: Hans Joachim Desserud (hjd) → nobody
GunChleoc (gunchleoc) wrote :

Fixed in build20-rc1

Changed in widelands:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers