State of buttons in statistics menu sometimes not shown correctly

Bug #1686165 reported by kaputtnik on 2017-04-25
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
widelands
Low
Unassigned

Bug Description

Steps to reproduce:

1. open statistics menu
2. Click buildings statistic (the button in statistic menu is shown pressed)
3. close statistic menu
4. open statistics menu again (the button of buildings statistic is now shown raised, while the buildings statistics window is still open)

Expected: The button should be shown pressed if the corresponding window is already open.

Something weird: Some times if you click the buildings statistics button in statistics menu, the Ware statistic button is shown pressed. Didn't found a way to reproduce, but had this several times.

GunChleoc (gunchleoc) wrote :

If I still manage to implement drop-up menus from the main toolbar before Build 20, this point will become moot.

tags: added: lowhangingfruit ui
Changed in widelands:
status: New → Confirmed
milestone: none → build20-rc1
importance: Undecided → Medium
importance: Medium → Low
Jukka Pakarinen (flegu) wrote :

I can't reproduce this. I used trunk revno 8551 on Debian 9. The button stays pressed after reopening the statistics menu. I tried to close the menu in two different ways: right clicking the menu window and left clicking the Statistics button. Keyboard shortcut 'S' didn't work at all.

kaputtnik (franku) wrote :

Indeed, i can't reproduce this also anymore. So this is magically fixed :-)

The 'S' key switches statistics on shown directly on top of each building. This works here as expected.

Changed in widelands:
status: Confirmed → Fix Committed
Jukka Pakarinen (flegu) wrote :

I didn't figurered out that the 's' key shows statistics on top of each building. When I tried the key there wasn't any building, except the headquater. My mistake!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers