Misnamed Buildings (En_GB translation)

Bug #1652923 reported by Ben Dare on 2016-12-28
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
widelands
Undecided
Unassigned
widelands (Debian)
Confirmed
Unknown

Bug Description

Hi there, thanks, first bug-report (apologies if clumsy)
Playing in Windows 7 Professional (6.1.7601 Service Pack 1 Build 7601).
Widelands Version build-19 (Release) - English-GB translation

I am currently played the beginner's tutorials and am on the 3rd mission of the 1st Barbarian Campaign. I have noticed that a number of buildings are wrongly named (or confusingly named) in these places:
Tribal Encyclopedia
New Building Selection menus
On-screen building name tags

The Barbarian buildings are:
Ranger's Hut/Forester - called "Fishemanr's Hut"*
Hunter's Hut - called "Fishemanr's Hut"*
Fisherman's Hut - called "Fishemanr's Hut" (right name, but wrong spelling)*
Charcoal Burner - called "Coal Mine"
Coal Mine - called "Deep Coal Mine"*
Cloth-maker/Weaver - called "War Mill"*

Imperial Buildings:
Charcoal Burner - called "Coal Mine"
Coal Mine - called "Deep Coal Mine"*
Cloth-maker/Weaver - called "War Mill"
Armour Smithy - called "Weapon Smithy"*

Atlantean Buildings
Charcoal Burner - called "Coal Mine"
Coal Mine - called "Deep Coal Mine"
Cloth-maker/Weaver - called "War Mill"
Armour Smithy - called "Weapon Smithy"*

The ones marked with * are just to indicate that there are therefore more than one building with the same name, which can lead to building mistakes.
Loving the game, just thought I should pass this on.
Ben

PS. Didn't think a savegame was necessary to show this, but let me know if some attachment would help.

kaputtnik (franku) wrote :

Thanks for this bugreport :-)

This was caused by a bad translation... and i thought it was fixed also for build 19. At least the Archlinux version do not show these wrong namings anymore. I guess one had forgotton to update the binary for Windows?

An understandable mistake!

On 30/12/2016 09:59, kaputtnik wrote:
> Thanks for this bugreport :-)
>
> This was caused by a bad translation... and i thought it was fixed also
> for build 19. At least the Archlinux version do not show these wrong
> namings anymore. I guess one had forgotton to update the binary for
> Windows?
>

---
This email has been checked for viruses by Avast antivirus software.
https://www.avast.com/antivirus

Tino (tino79) wrote :

I've reported this to Gunchleoc at the beginning of November and as far as i can see was this fixed with revision 8173 in trunk.

But sadly this was quite some time after the code/translation freeze for B19, so this fix did not make it into B19.

Changed in widelands:
status: New → Fix Committed
milestone: none → build20-rc1
Ben Dare (bendare) wrote :

Ta!

On 30/12/2016 11:44, Tino wrote:
> I've reported this to Gunchleoc at the beginning of November and as far
> as i can see was this fixed with revision 8173 in trunk.
>
> But sadly this was quite some time after the code/translation freeze for
> B19, so this fix did not make it into B19.
>
> ** Changed in: widelands
> Status: New => Fix Committed
>
> ** Changed in: widelands
> Milestone: None => build20-rc1
>

---
This email has been checked for viruses by Avast antivirus software.
https://www.avast.com/antivirus

Hans Joachim Desserud (hjd) wrote :

Fwiw, this issue has also been reported in Debian (see the attached bug watch)

affects: debian → widelands (Debian)
tags: added: internationalization
Ben Dare (bendare) wrote :

Cool ta. That's a sensibly written bug report.

> On 3 Feb 2017, at 20:48, Hans Joachim Desserud <email address hidden> wrote:
>
> Fwiw, this issue has also been reported in Debian (see the attached bug
> watch)
>
> ** Bug watch added: Debian Bug tracker #853052
> http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=853052
>
> ** Also affects: debian via
> http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=853052
> Importance: Unknown
> Status: Unknown
>
> ** Package changed: debian => widelands (Debian)
>
> ** Tags added: internationalization
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1652923
>
> Title:
> Misnamed Buildings (En_GB translation)
>
> Status in widelands:
> Fix Committed
> Status in widelands package in Debian:
> Unknown
>
> Bug description:
> Hi there, thanks, first bug-report (apologies if clumsy)
> Playing in Windows 7 Professional (6.1.7601 Service Pack 1 Build 7601).
> Widelands Version build-19 (Release) - English-GB translation
>
> I am currently played the beginner's tutorials and am on the 3rd mission of the 1st Barbarian Campaign. I have noticed that a number of buildings are wrongly named (or confusingly named) in these places:
> Tribal Encyclopedia
> New Building Selection menus
> On-screen building name tags
>
> The Barbarian buildings are:
> Ranger's Hut/Forester - called "Fishemanr's Hut"*
> Hunter's Hut - called "Fishemanr's Hut"*
> Fisherman's Hut - called "Fishemanr's Hut" (right name, but wrong spelling)*
> Charcoal Burner - called "Coal Mine"
> Coal Mine - called "Deep Coal Mine"*
> Cloth-maker/Weaver - called "War Mill"*
>
> Imperial Buildings:
> Charcoal Burner - called "Coal Mine"
> Coal Mine - called "Deep Coal Mine"*
> Cloth-maker/Weaver - called "War Mill"
> Armour Smithy - called "Weapon Smithy"*
>
> Atlantean Buildings
> Charcoal Burner - called "Coal Mine"
> Coal Mine - called "Deep Coal Mine"
> Cloth-maker/Weaver - called "War Mill"
> Armour Smithy - called "Weapon Smithy"*
>
> The ones marked with * are just to indicate that there are therefore more than one building with the same name, which can lead to building mistakes.
> Loving the game, just thought I should pass this on.
> Ben
>
> PS. Didn't think a savegame was necessary to show this, but let me
> know if some attachment would help.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/widelands/+bug/1652923/+subscriptions

Changed in widelands (Debian):
status: Unknown → Confirmed
Martin Quinson (mquinson) wrote :

Is it OK to apply the revision 8173 on top of Build 19 to fix the issue, or should I restrict it to en_GB files only? I mean, did the strings change between the release of Build 19 and revision 8173?

Thanks for your time,
Mt.

GunChleoc (gunchleoc) on 2017-05-14
Changed in widelands:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.