Scenario: A player slot could be chosen with no effect

Bug #1613870 reported by kaputtnik on 2016-08-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
widelands
Fix Released
High
Unassigned

Bug Description

Steps to reproduce:

- Select a Scenario (f.e. 'The green plateau')
- In menu "Launch Game" you could choose to play as another player (f.e. red player)

Result:
Starting the game you'll find yourself as the blue player, not the one you have chosen

Expected result:
Selecting another Player in menu "Launch Game" should not be possible if the scenario doesn't support this. Or: Immediately start the game without showing the menu "launch game" like it is when playing campaigns.

Reported in the forum by toptopple: https://wl.widelands.org/forum/topic/2051/

Related branches

kaputtnik (franku) on 2016-08-16
description: updated
SirVer (sirver) wrote :

pretty sure this is a regression - but even if it is not, this is a fairly bad bug that needs fixing for b19.

Whoever tackles this should also look into multiplayer scenarios (for example island hopping) and see if choosing positions works as expected there.

Changed in widelands:
status: New → Confirmed
milestone: none → build19-rc1
importance: Undecided → High
kaputtnik (franku) on 2016-08-17
tags: added: scenario ui
SirVer (sirver) wrote :

I investigated and think that it is a bug that the UI allows for switching positions in single player scenarios. Since they are designed for one player only, it is easiest for the map designer to build it for a specific starting position - giving the ability to swap the starting position.

If a player wants to design a scenario that can be interesting from multiple positions, she can make a multiplayer scenario which allows for that.

I pushed a fix and proposed for merging.

Changed in widelands:
assignee: nobody → SirVer (sirver)
status: Confirmed → In Progress
GunChleoc (gunchleoc) on 2016-08-29
Changed in widelands:
status: In Progress → Fix Committed
assignee: SirVer (sirver) → nobody
GunChleoc (gunchleoc) on 2016-10-25
Changed in widelands:
status: Fix Committed → Fix Released
GunChleoc (gunchleoc) wrote :

Fixed in build19-rc1.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers