--dedicated issues: needs X, not killable, thrashes X

Bug #1416864 reported by Jens Beyer on 2015-02-01
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
widelands
Fix Released
Medium
Unassigned

Bug Description

If running --dedicated without X server it crashes with no valid video driver.

If running --dedicated with X running, a black window comes up, it does not fork (as mentioned in bug 1330068), and I can not close the window, and not close the process by ^C. After KDE brings up the Popup to close the program, deciding to close the program thrashes the X server (100% cpu, not responding anymore, no entry in the log).

hjd mentioned he was able to kill the widelands process. I do not know what KDE process killing does differently as this did not work for me. I did not try to kill the widelands process on the console.

Related branches

description: updated
Hans Joachim Desserud (hjd) wrote :

I got the same result when testing with r7374 in a VM.

> I did not try to kill the widelands process on the console.

I ran `ps -ef | grep widelands` and got the PID. I first tried `kill`, which didn't have any effect, so I had to use `kill -9`.

I know we have discussed dedicated and the need for graphics before. I could only find bug 1322869 right now, though I believe there was a related issue found by scan-build?

Changed in widelands:
importance: Undecided → Medium
milestone: none → build19-rc1
status: New → Triaged
tags: added: dedicated graphic multiplayer
SirVer (sirver) wrote :

--dedicated is a hack build into the game because hosting is hard - opening ports and so on. The correct solution here is to make hosting easy (through the proxy we have discussed a few times already). I'd much rather somebody spent time in building this proxy than fixing dedicated.

The design of dedicated assumes that no Graphics() object is created. That means that everywhere g_gr is used and the code can pass by (many places) we now need a if (g_gr) /* not in dedicated mode */. That is fragile and has probably broken in the last 100 commits or so - since there are no tests it would not have been noticed.

I am not sure if dedicated even directly jumps into the game logic anymore - the code is super hard to follow.

SirVer (sirver) on 2016-02-06
Changed in widelands:
assignee: nobody → SirVer (sirver)
SirVer (sirver) wrote :

--dedicated is gone, so this bug is gone too.

Changed in widelands:
status: Triaged → Fix Committed
assignee: SirVer (sirver) → nobody
GunChleoc (gunchleoc) on 2016-10-10
tags: added: graphics network
removed: dedicated graphic
GunChleoc (gunchleoc) on 2016-10-25
Changed in widelands:
status: Fix Committed → Fix Released
GunChleoc (gunchleoc) wrote :

Fixed in build19-rc1.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints