savegame does not load

Bug #1413734 reported by Kristin on 2015-01-22
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
widelands
High
Unassigned

Bug Description

In a tournament game (Group 1, juma vs Empire's Citadel), a savegame could be loaded by the hoster, but not by the other players and not by me. The game crashes when trying to open the savegame.

Game version is r7358.
The game has 3 savegames because there where network problems (probably not due to widelands but to the player's network).

Related branches

Kristin (ha-kripo) wrote :
TiborB (tiborb95) wrote :

perhaps in relation to this: bug-1388255

if there were AI players in the game....

fixed in rev. 7360

SirVer (sirver) wrote :

Nope, no AI in the game. The problem seems to be related to the Mac OS nightlies - I cannot reproduce it on my clang build, but it happens reproducable on the nighlies.

Changed in widelands:
status: New → Confirmed
importance: Undecided → High
assignee: nobody → SirVer (sirver)
milestone: none → build19-rc1
SirVer (sirver) wrote :

Update: I can trigger the problem with a release build on my machine too. So it seems to be a debug <=> release issue.

SirVer (sirver) wrote :

I filed an upstream bug for this issue: https://github.com/fnuecke/eris/issues/14#issuecomment-71318776

I also fixed it for the future in our repo in r7368, the posted replays stay corrupt though.

Changed in widelands:
status: Confirmed → Fix Committed
assignee: SirVer (sirver) → nobody
GunChleoc (gunchleoc) on 2016-10-25
Changed in widelands:
status: Fix Committed → Fix Released
GunChleoc (gunchleoc) wrote :

Fixed in build19-rc1.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers