Terrain names in terrains/init.lua incosistent

Bug #1374831 reported by TiborB on 2014-09-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
widelands
Undecided
Unassigned

Bug Description

Hi

Terrain names in world/terrains/init.lua are not consistent, example:
descname = _ "Mountain 1",
descname = _ "Mountain 2",
descname = _ "Mountain 3",
descname = _ "Mountain 4",
descname = _ "Mountain 1 (Winter)",
descname = _ "Mountain 2 (Winter)",
descname = _ "Mountain 3 (Winter)",
descname = _ "Mountain 4 (Winter)",

Note the parenthesis. Sometimes there are one, sometime there are none.
So I suggest unification. Or alternativelly have parenthesis with world only if the type of terrain is not unique, like "Mountains" in above example.

For more info see also here: https://code.launchpad.net/~widelands-dev/widelands/bug-1174075/+merge/235763

Related branches

GunChleoc (gunchleoc) wrote :

I would be comfortable with one of the following 2 options:

1. Rename "Mountain 1 (Winter)" etc. to "Winter Mountain 1" etc.

2. In the terrain editor, we already know it's a Winter mountain, because we will be in the "Winter" tab. So, the only place the names make a difference is the info tool. Is it important there? If the users of the info tool don't care, we could just rename "Mountain 1 (Winter)"etc. to "Mountain 1" etc. We could then also add a terrain category entry to the infotool, the same one we use for the tabs in the terrain tool.

I prefer option 2., but I'm not using the editor myself, so I would like to hear from others on this before I do anything.

Changed in widelands:
status: New → Confirmed
GunChleoc (gunchleoc) on 2014-09-28
tags: added: editor lowhangingfruit ui
TiborB (tiborb95) wrote :

to me both solutions looks acceptable

kaputtnik (franku) wrote :

If the numbering ("Mountain #") isn't needed internally, this number could be ommitted too. The main information of "Mountain" is "you could place only mines here". For a map creator the numbering is useless.

GunChleoc (gunchleoc) on 2015-01-30
Changed in widelands:
milestone: none → build19-rc1
assignee: nobody → GunChleoc (gunchleoc)
status: Confirmed → In Progress
GunChleoc (gunchleoc) on 2015-01-30
Changed in widelands:
status: In Progress → Fix Committed
GunChleoc (gunchleoc) on 2016-02-15
Changed in widelands:
assignee: GunChleoc (gunchleoc) → nobody
GunChleoc (gunchleoc) on 2016-10-25
Changed in widelands:
status: Fix Committed → Fix Released
GunChleoc (gunchleoc) wrote :

Fixed in build19-rc1.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers