Comment 10 for bug 1220546

Hans Joachim Desserud (hjd) wrote :

Not quite fixed just yet. We just got a ftbfs on Precise because it claims the version of boost is too old [1]. I think I've mentioned this before, but it turns out in Ubuntu 12.04 libboost-dev version depends on libboost1.46-dev which will be installed by default [2]. So even though the generic -dev package fullfills the version number requirement it will pull in an older version. Somehow we need to force it to install the later version without breaking later releases by looking for a specific package version. I think if we tried to define the build dependency as "libboost1.48-dev | libboost-dev" it should look up the specific version or fall back to the generic one installing whichever qualifies. This is untested though...