Savegame crashes Widelands

Bug #1219507 reported by Joe on 2013-09-01
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
widelands
Medium
Unassigned

Bug Description

The attached savegame crashes Widelands. Wait a minute after loading the game, then Widelands crashes.
I am using bzr6737[trunk] on Windows 7 64Bit.

Joe (joe-kleine-schweiz) wrote :
Joe (joe-kleine-schweiz) wrote :

The map used for this savegame

Hans Joachim Desserud (hjd) wrote :

Thanks for reporting this issue and providing a save game.

I was able to reproduce the crash by loading the attached savegame and letting it run for a short while in Widelands r6738. I've attached a backtrace.

Changed in widelands:
importance: Undecided → Medium
milestone: none → build18-rc1
status: New → Confirmed
tags: added: crash savegame
Nasenbaer (nasenbaer) wrote :

Seems to be a bug in the military fighting code

tags: added: military
SirVer (sirver) on 2013-09-14
Changed in widelands:
status: Confirmed → In Progress
assignee: nobody → SirVer (sirver)
SirVer (sirver) wrote :

indeed - fixed.

Changed in widelands:
status: In Progress → Fix Committed
assignee: SirVer (sirver) → nobody
SirVer (sirver) wrote :

Released in build-18 rc1.

Changed in widelands:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers