bzr 6718 segfault building expedition port

Bug #1211898 reported by willem on 2013-08-13
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
widelands
High
Unassigned

Bug Description

compiled from source on linux

map crossing the horizon

segfault when dropping anchor from ship.

Program received signal SIGSEGV, Segmentation fault.
0x0000000000b5a2e4 in Widelands::Index_<Widelands::Building_Index>::Index_ (
    this=0x7fffffff97af, other=...) at /home/wiz/widelands/widelands/src/logic/widelands.h:74
74 Index_(const Index_ & other = Null()) : i(other.i) {}

Hans Joachim Desserud (hjd) wrote :

Thanks for reporting this issue.

By following the provided steps, I was able to reproduce this issue in r6718.

Changed in widelands:
importance: Undecided → High
milestone: none → build18-rc1
status: New → Confirmed
tags: added: crash regression seafaring ui
Nasenbaer (nasenbaer) wrote :

I am currently working on seafaring.

I will take a look at it.

Thanks for reporting

Changed in widelands:
assignee: nobody → Nasenbaer (nasenbaer)
Nasenbaer (nasenbaer) wrote :

This was quite a bit different than I initially thought... anyway the fix was committed with bzr rev. 6720 :).

Changed in widelands:
status: Confirmed → Fix Committed
assignee: Nasenbaer (nasenbaer) → nobody
willem (wiz-e) wrote :

Works for me, thank you.

SirVer (sirver) wrote :

Released in build-18 rc1.

Changed in widelands:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers